Closed Bug 691271 Opened 8 years ago Closed 8 years ago

Crash mainly close to startup in [@ DebugBreak ] [@ DbgBreakPoint ] with Roboform

Categories

(Firefox :: General, defect, critical)

8 Branch
defect
Not set
critical

Tracking

()

RESOLVED WORKSFORME
Tracking Status
firefox8 - ---

People

(Reporter: scoobidiver, Unassigned)

References

Details

(Keywords: crash, regression, Whiteboard: [Fixed in Roboform 7.6.2])

Crash Data

It's #1 top crasher in 8.0b1.
It happens at startup with Roboform 7.5.1.

Stack traces are as follow:
0 	KERNELBASE.dll 	DebugBreak 	
1 	xul.dll 	Break 	xpcom/base/nsDebugImpl.cpp:483
2 	xul.dll 	NS_DebugBreak_P 	xpcom/base/nsDebugImpl.cpp:328
3 	rf-firefox.dll 	rf-firefox.dll@0x11048 	
4 	rf-firefox.dll 	rf-firefox.dll@0x10f41 	
5 	rf-firefox.dll 	rf-firefox.dll@0x10cd9 	
6 	rf-firefox.dll 	rf-firefox.dll@0x10d56 	
7 	rf-firefox.dll 	rf-firefox.dll@0x10bee 	
8 	rf-firefox.dll 	rf-firefox.dll@0x506e 	
9 	rf-firefox.dll 	rf-firefox.dll@0x50e8 	
10 	roboform.dll 	roboform.dll@0x45b9a0 	
11 	roboform.dll 	roboform.dll@0x45b230 	
12 	user32.dll 	DispatchHookW 	
13 	user32.dll 	CallHookWithSEH 	
14 	user32.dll 	__fnHkINLPMSG 	
15 	ntdll.dll 	KiUserCallbackDispatcher 	
16 	ntdll.dll 	KiUserApcDispatcher 	
17 	KeyScramblerIE.dll 	KeyScramblerIE.dll@0x65fc 	
18 	user32.dll 	CallHookWithSEH 	
19 	user32.dll 	__fnHkINLPMSG 	
20 	ntdll.dll 	KiUserCallbackDispatcher 	
21 	ntdll.dll 	KiUserApcDispatcher 	
22 	user32.dll 	_PeekMessage 	
23 	xul.dll 	nsAppShell::ProcessNextNativeEvent 	widget/src/windows/nsAppShell.cpp:339
24 	xul.dll 	nsBaseAppShell::OnProcessNextEvent 	widget/src/xpwidgets/nsBaseAppShell.cpp:306
25 	xul.dll 	nsThread::ProcessNextEvent 	xpcom/threads/nsThread.cpp:595
26 	winmm.dll 	timeGetTime 	
27 	xul.dll 	NS_ProcessPendingEvents_P 	obj-firefox/xpcom/build/nsThreadUtils.cpp:195
28 	xul.dll 	nsWindow::DispatchPendingEvents 	widget/src/windows/nsWindow.cpp:3702

Frame 	Module 	Signature [Expand] 	Source
0 	ntdll.dll 	DbgBreakPoint 	
1 	xul.dll 	Break 	xpcom/base/nsDebugImpl.cpp:483
2 	xul.dll 	NS_DebugBreak_P 	xpcom/base/nsDebugImpl.cpp:328
3 	rf-firefox.dll 	rf-firefox.dll@0x10f78 	
4 	rf-firefox.dll 	rf-firefox.dll@0x10e71 	
5 	rf-firefox.dll 	rf-firefox.dll@0x10be9 	
6 	rf-firefox.dll 	rf-firefox.dll@0x10c66 	
7 	rf-firefox.dll 	rf-firefox.dll@0x10afe 	
8 	rf-firefox.dll 	rf-firefox.dll@0x503e 	
9 	rf-firefox.dll 	rf-firefox.dll@0x50a8 	
10 	roboform.dll 	roboform.dll@0x45bf50 	
11 	roboform.dll 	roboform.dll@0x45b7e0 	
12 	user32.dll 	DispatchHookW 	
13 	user32.dll 	CallHookWithSEH 	
14 	user32.dll 	__fnHkINLPMSG 	
15 	ntdll.dll 	KiUserCallbackDispatcher 	
16 	roboform.dll 	roboform.dll@0x45b1df 	
17 	user32.dll 	NtUserPeekMessage 	
18 	xul.dll 	nsAppShell::ProcessNextNativeEvent 	widget/src/windows/nsAppShell.cpp:339
19 	xul.dll 	nsBaseAppShell::OnProcessNextEvent 	widget/src/xpwidgets/nsBaseAppShell.cpp:306
20 	xul.dll 	nsThread::ProcessNextEvent 	xpcom/threads/nsThread.cpp:595
21 	winmm.dll 	timeGetTime 	
22 	xul.dll 	NS_ProcessPendingEvents_P 	obj-firefox/xpcom/build/nsThreadUtils.cpp:195
23 	xul.dll 	nsWindow::DispatchPendingEvents 	widget/src/windows/nsWindow.cpp:3702

More reports at:
https://crash-stats.mozilla.com/report/list?signature=DebugBreak
https://crash-stats.mozilla.com/report/list?signature=DbgBreakPoint
you should upgrade to RF ver 7.5.2

also we will have rel 7.5.3 that fixes more problems.
It happens also in Roboform 7.5.2.
Summary: Startup crash in [@ DebugBreak ] [@ DbgBreakPoint ] with Roboform 7.5.1 → Startup crash in [@ DebugBreak ] [@ DbgBreakPoint ] with Roboform 7.5.2
we will have 7.5.3 later today, 
it will fix two more crashes.
RoboForm 7.5.3 has been released
I have just tried RF 7.5.3 and still experience a crash
yes, there is a few crashes remaining, 20 times less then there before.

we plan to fix remaining crashes in ver 7.5.4, to come out this friday.
Summary: Startup crash in [@ DebugBreak ] [@ DbgBreakPoint ] with Roboform 7.5.2 → Startup crash in [@ DebugBreak ] [@ DbgBreakPoint ] with Roboform 7.5.3
(In reply to Vadim Maslov from comment #6) 
> we plan to fix remaining crashes in ver 7.5.4, to come out this friday.
It still occurs in Roboform 7.5.5:
bp-fadb03c8-b4d5-499b-a76d-cf1502111012
Summary: Startup crash in [@ DebugBreak ] [@ DbgBreakPoint ] with Roboform 7.5.3 → Crash mainly close to startup in [@ DebugBreak ] [@ DbgBreakPoint ] with Roboform
RF ver 7.5.6 comes out today, it should fix remaining minor crashes.
I got this today after restaring Aurora.  It continued to occur every time I started Aurora (even when trying to load in safe mode).  I have to load the release version of Firefox in order to run (didn't try beta).  The nightly branch appears to load though as I was using that briefly before switching to Aurora.

I'm running RF2Go 7.5.7

bp-fe7f697a-51ea-4831-918b-825892111020
bp-3fb9fa0e-2591-449e-9753-d39b12111020
I just realized I was actually running 8.0a (my Beta and Aurora files were way out of date).  I upgraded to the latest of each, but the Beta (8) and Aurora (9) branches are still crashing.

Beta - bp-995619d2-1f75-44c7-bd4a-eb75d2111020  
Aurora - bp-5634d3cc-4da2-432c-8dbc-bdae02111020

They will (usually) run the first time I run them, but any subsequent times they will crash.

The release (7) and nightly (10) loads load up fine though.  It's only a problem in the 8 and 9 branches.
I'll point out that it also crashes with the regular Roboform 7.5.7 under Windows XP SP3 in Firefox 8 and Firefox 9.  Firefox 10 does not crash.
ok, we have this private rel, to become public on monday:
http://www.roboform.com/dist/RoboForm-Setup-7-5-8.exe

does it crash?

we cannot reproduce any crahses in RF + FF now.
Here's my results when testing 7.5.8.

If the Roboform add-on is enabled:

1. The release (7.0.1), Aurora (9.0a2) and Nightly (10.x) loads of Firefox will work.
2. The Beta (8) version of Firefox will crash if the robotaskbaricon.exe program is running (i.e. the Roboform icon is in the system tray) and the "Browser Integration" option to "Attach Roboform to Firefox even if Adapter is not installed" is checked.  If that option is not checked or the robotaskbaricon.exe program isn't running the beta load will not crash.


If the Roboform Firefox add-on is disabled or uninstalled and the robotaskbaricon.exe program is running (i.e. the Roboform icon is in the system tray) and the "Browser Integration" option to "Attach Roboform to Firefox even if Adapter is not installed" is checked:

1. Firefox release version (7.0.1) works fine and Roboform attaches to the process.
2. Beta (8.0) and Aurora (9.0a2) versions crash on start up when Roboform tries to attach itself.
3. The Nightly load won't crash, but then Roboform won't attach to the nightly load if the add-on is disabled even if the "Attach Roboform to Firefox even if Adapter is not installed" setting is checked.  So Roboform won't actually work in the Nightly load without that add-on installed and enabled.


So it's a bit better, but not perfect.  Everything will work as long as the "Attach Roboform to Firefox even if Adapter is not installed" setting is not checked.  If it is, crashes will occur in non-release versions of Firefox depending on whether or not the Firefox add-on is enabled (only beta crashes) or not (beta and aurora crashes).

It sounds like you don't want to have the Roboform system tray icon try to attach to non-release loads.  Though that would probably break Roboform2Go in the beta and aurora loads, but it crashes in those loads currently anyway.

Here's some crash reports:
bp-c1614a54-9683-47b7-a47a-c9de82111022 - Firefox 8 Roboform add-on enabled  (attach option enabled)
bp-6b7c16c7-040d-4cb1-bcd2-941522111022 - Firefox 8 Roboform add-on disabled (attach option enabled)
bp-8b051a6e-629d-4339-9e8f-208642111022 - Firefox 9 Roboform add-on disabled (attach option enabled)




On an unrelated note, I notice that the following warning displays in the console when Firefox is shutting down:

*** WARN addons.xpi: Exception running bootstrap method shutdown on {22119944-ED35-4ab1-910B-E619EA06A115}: [Exception... "Not enough arguments [nsIStyleSheetService.unregisterSheet]" nsresult: "0x80570001 (NS_ERROR_XPC_NOT_ENOUGH_ARGS)" location "JS frame :: resource:///modules/XPIProvider.jsm -> file:///C:/Program%20Files/Siber%20Systems/AI%20Roboform/Firefox/bootstrap.js -> resource://roboform/content/roboform :: zdi :: line 45" data: no]
fixed in RF 7.5.9
I'm still seeing a crash shortly after start up in the following circumstances in the Beta (8.0) and Aurora (9.0a2) builds when running RF 7.5.9:

1. Beta will always crash if the robotaskbaricon.exe program is running (i.e. the Roboform icon is in the system tray) and the "Browser Integration" option to "Attach Roboform to Firefox even if Adapter is not installed" is checked. This happens whether or not the Roboform Toolbar for Firefox 7.5.9 add-on is installed and enabled or not.  bp-1ed91f43-f70f-48fb-913a-002442111024 bp-eba066f5-7d0b-448a-875d-289712111024

2. Aurora will always crash if the Roboform Toolbar for Firefox 7.5.9 add-on is not installed or not enabled, the robotaskbaricon.exe program is running (i.e. the Roboform icon is in the system tray) and the "Browser Integration" option to "Attach Roboform to Firefox even if Adapter is not installed" is checked. bp-7b813991-e122-4447-a37a-0fd1f2111024


Basically the same crashes I reported in comment #13.

I tested with Roboform 7.5.9 under Windows XP SP3.  I didn't test Roboform2Go.
Actually 7.5.9 is worse than 7.5.8 as it appears to prevent installing add-ons in Firefox 7.0.1 and causes the Error console to fill up with the following errors:

Error: zcu.zzb is not a constructor
Source file: resource:///modules/XPIProvider.jsm -> file:///C:/Program%20Files/Siber%20Systems/AI%20RoboForm/Firefox/bootstrap.js -> resource://roboform/content/roboform.js
Line: 323

roboform> zadc: TypeError: zcu.zwu is not a constructor @resource:///modules/XPIProvider.jsm -> file:///C:/Program%20Files/Siber%20Systems/AI%20RoboForm/Firefox/bootstrap.js -> resource://roboform/content/roboform.js(301)
Okay I see 7.6.0 is out and fixes the errors from comment #16.  I ran the same tests I did from comment #15 and the same crashes that occurred in 7.5.9 are also occurring in 7.6.0 with one exception.  Now none of the Firefox branches will crash as long as the Roboform Toolbar for Firefox 7.5.9 add-on is installed and enabled.

The Beta and Aurora branches will still crash if the the Roboform Toolbar for Firefox 7.5.9 add-on is disabled or not installed and the the robotaskbaricon.exe program is running (i.e. the Roboform icon is in the system tray) and the "Browser Integration" option to "Attach Roboform to Firefox even if Adapter is not installed" is checked.

Again tested with Roboform 7.6.0 under Windows XP SP3.
Same problem with RF 7.6.1.  Tested with Roboform2Go this time.  Needed to disable the "Attach Roboform to Firefox even if Adapter is not installed" to be able to run the Beta or Aurora loads since the Roboform Toolbar for Firefox isn't installed with RF2Go.
I got around to test RF 7.6.1 (the normal version) and it's actually a regression from 7.6.0.  

If the robotaskbaricon.exe program is running (i.e. the Roboform icon is in the system tray) and the "Browser Integration" option to "Attach Roboform to Firefox even if Adapter is not installed" is checked, the Beta and Aurora loads will crash on start up whether or not the Roboform Toolbar for Firefox 7.6.1 add-on is installed or not.

So again checking "Attach Roboform to Firefox even if Adapter is not installed" causes crashes in the Beta and Aurora loads.  

The work around for RF 7.6.1 is to not check that box (which is checked by default).

The work around for RF2Go 7.6.1 is to manually install the included add-on into any profile you want to run Firefox 8 or above with and uncheck the box.
Hello Michael: I am trying to reproduce this using Mozilla/5.0 (Windows NT 6.1; WOW64; rv:8.0) Gecko/20100101 Firefox/8.0 and using Roboform Toolbar for Firefox version 7.6.1.

1. I cannot seem to reproduce the startup crash you describe. I confirmed that the robotaskbaricon is running in task manager.
2. When creating a new account, I did see the box that says "Attach Roboform to Firefox.. checked by default.

Is there something else I am missing in the STR?

(In reply to Michael Kraft [:morac] from comment #19)
> I got around to test RF 7.6.1 (the normal version) and it's actually a
> regression from 7.6.0.  
> 
> If the robotaskbaricon.exe program is running (i.e. the Roboform icon is in
> the system tray) and the "Browser Integration" option to "Attach Roboform to
> Firefox even if Adapter is not installed" is checked, the Beta and Aurora
> loads will crash on start up whether or not the Roboform Toolbar for Firefox
> 7.6.1 add-on is installed or not.
> 
> So again checking "Attach Roboform to Firefox even if Adapter is not
> installed" causes crashes in the Beta and Aurora loads.  
> 
> The work around for RF 7.6.1 is to not check that box (which is checked by
> default).
> 
> The work around for RF2Go 7.6.1 is to manually install the included add-on
> into any profile you want to run Firefox 8 or above with and uncheck the box.
From my testing, if the roboformtaskbar executable tries to attach to Firefox 8 or 9, which it will if the "attach..." setting is checked, then the browser will crash.  I've tested one two different different machines (a laptop using RF and a desktop using RF2Go)  and both crash Firefox.  They are Windows XP SP3 machines though. 

It's easier to cause the crash if the Roboform addon is disabled, but I've found that not usually necessary.  The key though is to try to get the roboformtaskbar executable to try to attach itself to the Firefox 8 or 9 process.  My guess is that it's not hooking into the correct spot for those versions. 

You can see from the Crash Reports that crashes are still occurring with RF 7.6.1:

https://crash-stats.mozilla.com/report/list?product=Firefox&query_search=signature&query_type=exact&query=DbgBreakPoint&reason_type=contains&date=10%2F27%2F2011%2018%3A19%3A02&range_value=1&range_unit=weeks&hang_type=any&process_type=any&do_query=1&signature=DbgBreakPoint
new RF version 7.6.2 was released.

should be fixed
Well the good news is that all the crashing is gone so this bug can be closed.
The bad news is that 7.6.2 breaks Roboform2Go.

The "Attach Roboform to Firefox even if Adapter is not installed" doesn't work even in the Firefox release version.  If the add-on isn't installed, then the Roboform toolbar won't show up in any version of Firefox (including 7.0.1).

That's not really an issue for Roboform, but pretty much breaks Roboform2Go as it doesn't install the add-on.

I couldn't actually test Roboform2Go as the computer I was testing on has Roboform installed on it and Roboform2Go uses that if it's installed.  I'll need to test this on my work PC on Monday.
Okay I tested Roboform2Go and it works perfectly.  It does attach to Firefox 7,8 and 9.  Apparently the roboformtaskbar executable now only tries to attach if the Roboform Toolbar for Firefox isn't installed, which is fine I guess.

I believe this can be marked as fixed or withdrawn or whatever it is you do with bugs caused by add-ons.
[Triage Comment]
* Minusing tracking-firefox8 since this was resolved through an add-on update.
(In reply to Michael Kraft [:morac] from comment #24)
> I believe this can be marked as fixed or withdrawn or whatever it is you do
> with bugs caused by add-ons.

Based on that, marking as FIXED. Will reopen if we see crashes on our radar still.
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
Whiteboard: [Fixed in Roboform 7.6.2]
Blocks: 699134
It's not a code correction, but an extension correction.
Resolution: FIXED → WORKSFORME
Adding the new signature since it is showing up in 8 data correlated to older versions of Roboform.
Crash Signature: [@ DebugBreak ] [@ DbgBreakPoint ] → [@ DebugBreak ] [@ DbgBreakPoint ] [@ kernelbase.dll@0x31f66 ]
(In reply to Swarnava Sengupta (:Swarnava) from comment #29)
> DbgBreakpoint on Firefox 8.0.1
> https://crash-stats.mozilla.com/report/index/90f61dce-3ceb-4e80-acf0-
> 072842111126

You're using version 7.4.4 of Roboform.  Upgrade to the latest version (or at least 7.6.2).
I found it on support.mozilla forum, i already suggest him to upgrade, but my question is the crash is already fixed in version 8.0.1?
(In reply to Swarnava Sengupta (:Swarnava) from comment #31)
> I found it on support.mozilla forum, i already suggest him to upgrade, but
> my question is the crash is already fixed in version 8.0.1?

The problem is in the Roboform plugin (which was using it's own made up SDK instead of the official Mozilla SDK), not Firefox so it can't be "fixed" in Firefox.
yes, you must be using latest RoboForm version 
which is now 7.6.4.

earlier versions had crashes in firefox.
(In reply to Michael Kraft [:morac] from comment #32)
> (In reply to Swarnava Sengupta (:Swarnava) from comment #31)
> > I found it on support.mozilla forum, i already suggest him to upgrade, but
> > my question is the crash is already fixed in version 8.0.1?
> 
> The problem is in the Roboform plugin (which was using it's own made up SDK
> instead of the official Mozilla SDK), not Firefox so it can't be "fixed" in
> Firefox.

(In reply to Vadim Maslov from comment #33)
> yes, you must be using latest RoboForm version 
> which is now 7.6.4.
> 
> earlier versions had crashes in firefox.

thanks for clearifying :)
(In reply to Michael Kraft [:morac] from comment #32)
> The problem is in the Roboform plugin (which was using it's own made up SDK
> instead of the official Mozilla SDK), not Firefox so it can't be "fixed" in
> Firefox.

Though I wonder why 8.0.1 loads the Roboform DLLs with those versions at all, they should be blocked.
Duplicate of this bug: 702489
You need to log in before you can comment on or make changes to this bug.