Browser window looses edges when dropping a tab if the window is in fullscreen mode [tab animation]

RESOLVED INVALID

Status

()

RESOLVED INVALID
8 years ago
7 years ago

People

(Reporter: andrei.domuta, Unassigned)

Tracking

({regression})

Trunk
x86
All
regression
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [qa+])

(Reporter)

Description

8 years ago
Build ID
Nightly: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:10.0a1) Gecko/20111002 Firefox/10.0a1

Steps to reproduce:
1. Launch Firefox on a clean profile and have only one tab available
2. Maximize the browser window and grab and drag the tab out of the tab strip
3. Without dropping the tab hit the F11 key to go fullscreen
4. When the animation to go fullscreen is visible, release the tab

Expected results:
In step 4 the fullscreen browser window with on tab should be visible

Actual results:
In step 4 the browser windows looses it's edges and only the content is displayed.

*Notes:
-> I encountered this issue with the current implementation of the Tab Animation Feature on NIGHTLY ONLY; it's not visible on the current aurora (9) or beta (8)
-> Here is a link to a screen video of the issue: https://skydrive.live.com/?cid=bc75b2c6fced798f&id=BC75B2C6FCED798F%21352#cid=BC75B2C6FCED798F&id=BC75B2C6FCED798F%21353
(Reporter)

Comment 1

8 years ago
> -> I encountered this issue with the current implementation of the Tab
> Animation Feature on NIGHTLY ONLY; it's not visible on the current aurora
> (9) or beta (8)

I could see this issue on Aurora and Beta as well, so this might be a regression from the behavior before the Tab Animation feature implementation (tracked in bug 455694)
Here you can clearly see the issue on Aurora:
https://skydrive.live.com/?cid=bc75b2c6fced798f&id=BC75B2C6FCED798F!354#cid=BC75B2C6FCED798F&id=BC75B2C6FCED798F!355

This issue could be solved if the F11 key would be disable while dNd a tab.
(Reporter)

Updated

8 years ago
Depends on: 689575
(Reporter)

Comment 2

8 years ago
I did some tests on other platforms and the issue is visible there as well in similar ways: 
-> on Mac, in step 4 when releasing the mouse key the tab is not dropped
-> on Ubuntu, in step 4 when releasing the mouse key, the browser window is cut at the right margin

Mozilla/5.0 (X11; Linux x86_64; rv:10.0a1) Gecko/20111003 Firefox/10.0a1
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:10.0a1) Gecko/20110929 Firefox/10.0a1
OS: Windows 7 → All
Hardware: x86_64 → x86
Blocks: 455694
(Reporter)

Updated

8 years ago
Keywords: regression
(Reporter)

Updated

8 years ago
Whiteboard: [qa+]

Comment 3

7 years ago
Patch in bug 455694 was backed out.
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.