Closed Bug 691297 Opened 9 years ago Closed 7 years ago

browser.showQuitWarning does not show warning on quit

Categories

(Firefox :: General, defect)

defect
Not set
normal

Tracking

()

RESOLVED WORKSFORME
Tracking Status
firefox30 --- unaffected

People

(Reporter: samuelmarks, Unassigned)

Details

User Agent: Mozilla/5.0 (Windows NT 6.2; WOW64; rv:7.0.1) Gecko/20100101 Firefox/7.0.1
Build ID: 20110928134238

Steps to reproduce:

Went to about:config, set browser.showQuitWarning to true


Actual results:

Was set to true, but when I went [Firefox]->{Exit} the browser closed without popping up the dialogue.


Expected results:

Dialogue should've popped up - like this one: http://www.bioteck.net/images/blog/firefox-save-tabs-on-exit.jpg

(used to work, stopped working in one of the later Fx6 updates, Fx7 same problem)
Confirmed. Firefox 18.0.2
Have both browser.showQuitWarning and browser.warnOnQuit set to True, but whether I click the red X or use File Exit, there is no warning.
browser.showQuitWarning is still broken in Nightly 30.
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Windows NT → All
Hardware: x86_64 → All
Summary: browser.showQuitWarning stopped working → browser.showQuitWarning does not show warning on quit
Version: 7 Branch → unspecified
Works for me, once I realized that the browser.showQuitWarning pref is only checked if session restore is not enabled (i.e. "When Nightly starts" setting is "Show my home page" or "Show a blank page", NOT "Show my windows and tabs from last time").
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.