Prefs and Chromefiles are opened more often than needed

VERIFIED DUPLICATE of bug 72551

Status

()

Core
General
VERIFIED DUPLICATE of bug 72551
17 years ago
10 years ago

People

(Reporter: Christian Mattar, Assigned: neeti)

Tracking

({perf})

Trunk
mozilla1.0.1
x86
Windows 98
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

47.48 KB, application/octet-stream
Details
(Reporter)

Description

17 years ago
I used a simple tool called "filemon" to monitor which files are opened by 
Mozilla during startup. If I interpret the log-file correctly, the Chrome.jar 
files are opened and closed several times subsequently, without actually reading 
any data (see item 15130 and following and 17942 and following of the 
attachment).
Similar for the prefs (see item 932 and following).

You can download the tool at http://www.sysinternals.com/

I have absolutely no idea what component this might be, so I put it to 
Browser-General.
(Reporter)

Comment 1

17 years ago
Created attachment 25480 [details]
Logfile of Filmeon

Updated

17 years ago
Depends on: 29063

Comment 2

17 years ago
Adding perf keyword and makring as blocker for bug 7251 (improve startup
performance tracking bug).
Blocks: 7251
Keywords: perf

Comment 3

17 years ago
over to toolkit for evaluation
Assignee: asa → trudelle
Component: Browser-General → XP Toolkit/Widgets
QA Contact: doronr → jrgm

Comment 4

17 years ago
->hyatt
Assignee: trudelle → hyatt

Comment 5

17 years ago
This is the JAR protocol.
Assignee: hyatt → neeti
Component: XP Toolkit/Widgets → Networking
QA Contact: jrgm → tever
(Assignee)

Updated

17 years ago
Target Milestone: --- → mozilla1.0.1

Comment 6

17 years ago
this sounds like bug 72551, which Dan Veditz has checked in a fix for it 
around 4/5/01.

Can reporter, Christian Matter cmattar@gmx.de, verify if this is indeed the same 
bug as 72551? 
(Reporter)

Comment 7

17 years ago
Looking at the filemon-logs, it seems to be much better, although there's still 
improvement to be made IMO.
I'll attach a new logfile with the important sections marked sometime later this 
afternoon.
(Reporter)

Comment 8

17 years ago
I checked the log-file again and it actually looks pretty good right now.
Marking as dup.

*** This bug has been marked as a duplicate of 72551 ***
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE

Updated

17 years ago
No longer blocks: 7251

Updated

17 years ago
Blocks: 7251

Comment 9

16 years ago
-> XP Misc + qa
Status: RESOLVED → VERIFIED
Component: Networking → XP Miscellany
QA Contact: tever → brendan

Updated

10 years ago
Component: XP Miscellany → General
QA Contact: brendan → general
You need to log in before you can comment on or make changes to this bug.