Add a toggle option in webdeveloper tools menu to active webdevelopers tools in Firefox

RESOLVED WONTFIX

Status

()

Firefox
Developer Tools: Framework
RESOLVED WONTFIX
6 years ago
a year ago

People

(Reporter: Zéfling, Unassigned)

Tracking

(Blocks: 1 bug)

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [mozfr-community])

(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (Windows NT 5.2; WOW64; rv:10.0a1) Gecko/20111003 Firefox/10.0a1
Build ID: 20111003030859

Steps to reproduce:

Add an option in the webdeveloper menu, not activated by default, because all non webdevelopers do not need “inspection” in contextual menu.
(Reporter)

Updated

6 years ago
OS: Windows Server 2003 → All
Hardware: x86_64 → All
Agreed, we have been trying to steamline the UI for Firefox in the last 2 years and the addition of the developer tools is adding a "Inspect this" item in the context menu. we should have an option in the tools to activate that instead of showing it to all of our user base.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Updated

6 years ago
Summary: Add a toggle option in webdeveloper tools menu for active webdeveloper function in Firefox → Add a toggle option in webdeveloper tools menu to active webdevelopers tools in Firefox

Updated

6 years ago
Component: General → Developer Tools
QA Contact: general → developer.tools
Version: 10 Branch → unspecified

Comment 2

6 years ago
I understand that. The "Inspect" feature is for the 2%-users described by Limi.

I see different possible options here:
1) we keep the "Inspect" menuitem by default
2) we show it if the user activate the "Web Developer" tools (in a menu or in the preference panel)
3) we show it only if the user has used the dev tools at least once (but then, how can we disable it?)

I would vote for the option 2. First, the "Web Developer" menuitem could be a check box (<menuitem type=checkbox>), once activated, it becomes a nested submenu (the one we have right now), and the "Inspect Element" menuitem in the context menu appears. Then, the way to disable it could be an extra menuitem in the "Web Developer" menu, called "disable developer tools".

How is that?

Comment 3

6 years ago
I'll note that bug 664589 would likely have a related solution.
As mihai pointed out in another discussion, all of the main browsers include an Inspect Element context menu option (maybe some require turning on developer tools, or maybe not). I'd consider this to be a lower-priority bug and could be done in a follow-up release if it's deemed necessary.

From an ideological perspective, do we want to hide our tools at all? If you consider the Highlighter to be like a next generation, interactive View Source, it will be a great learning tool for people interested in how a web page is put together. I think this is a good goal.
(In reply to Rob Campbell [:rc] (robcee) from comment #4)
> As mihai pointed out in another discussion, all of the main browsers include
> an Inspect Element context menu option (maybe some require turning on
> developer tools, or maybe not). I'd consider this to be a lower-priority bug
> and could be done in a follow-up release if it's deemed necessary.

I would add that Opera, Chrome and IE do not require any additional steps to turn on devtools. They have devtools available by default. Afaik, only Safari has an option in their Preferences dialog to enable devtools.
Moving this into Graphical Commandline and Toolbar. Still active.

Maybe one option would be to only enable the context menu if the Developer Toolbar is enabled and visible?
Component: Developer Tools → Developer Tools: Graphic Commandline and Toolbar
I think this is a UX decision.

But I would add that unless we also make our content menu inaccessible to addons then it could make firefox developer tools less easy to find than other tools, so while other browsers have an inspect menu item, I'm not keen on removing it.

(Also assigning to Framework, would prefer to think about it there rather than just as a toolbar item, even if that's how we implement this).
Component: Developer Tools: Graphic Commandline and Toolbar → Developer Tools: Framework

Comment 8

5 years ago
If I'm not mistaken, this has been discussed before (at a product and security level), and we dropped this idea of having an option to disable the developer tools.

About the context menu, there's an option in about:config to disable the context menu: devtools.inspector.enabled.

(In reply to Rob Campbell [:rc] (:robcee) from comment #6)
> Moving this into Graphical Commandline and Toolbar. Still active.
> 
> Maybe one option would be to only enable the context menu if the Developer
> Toolbar is enabled and visible?

The context menu is probably the most used way to access the inspector. Asking to start the toolbar first will make the inspector very hard to reach without a shortcut.

(In reply to Joe Walker [:joe_walker] [:jwalker] from comment #7)
> I think this is a UX decision.

Mostly product. It's about how much we want our tools to be discoverable.
And this has been discussed in the past.
I do agree that we want the Inspect Menu item to be available. Would adding a pref to remove it from the context menu, but default it to always showing the context menu item be terrible? It would only exist for the people who absolutely do not want it.

Maybe down the line we could ship with that pref turned off (i.e., showContextMenu = false) and turn it on the first time a user activates something from the Web Developer menu.

Comment 10

5 years ago
(In reply to Rob Campbell [:rc] (:robcee) from comment #9)
> Would adding
> a pref to remove it from the context menu, but default it to always showing
> the context menu item be terrible? It would only exist for the people who
> absolutely do not want it.

There's already a pref for that. But it's not exposed (only accessible from about:config).

> Maybe down the line we could ship with that pref turned off (i.e.,
> showContextMenu = false) and turn it on the first time a user activates
> something from the Web Developer menu.

I haven't heard enough complains. I like the idea, so let's keep that as something we could do if we start getting too many complains.
(In reply to Paul Rouget [:paul] ~~ offline until 1st of June from comment #10)
> (In reply to Rob Campbell [:rc] (:robcee) from comment #9)
> > Would adding
> > a pref to remove it from the context menu, but default it to always showing
> > the context menu item be terrible? It would only exist for the people who
> > absolutely do not want it.
> 
> There's already a pref for that. But it's not exposed (only accessible from
> about:config).

Maybe now we can place an option to toggle the context menu entry in the Options Panel (bug 851546)
(In reply to Girish Sharma [:Optimizer] from comment #11)
> (In reply to Paul Rouget [:paul] ~~ offline until 1st of June from comment
> #10)
> > (In reply to Rob Campbell [:rc] (:robcee) from comment #9)
> > > Would adding
> > > a pref to remove it from the context menu, but default it to always showing
> > > the context menu item be terrible? It would only exist for the people who
> > > absolutely do not want it.
> > 
> > There's already a pref for that. But it's not exposed (only accessible from
> > about:config).
> 
> Maybe now we can place an option to toggle the context menu entry in the
> Options Panel (bug 851546)

We could, but that would just make it even harder to find.

CCing shorlander and jgriffiths.

IMHO we should WONTFIX this for all the reasons above. If shorlander/jgriffiths don't disagree then I'll do that in a week or so.
IMO we should WONTFIX, simply because it makes the dev tools much less discoverable. We need this UI hook in this particular place so that we do not violate the expectations of web developers. Happy to discuss if Stephen feels differently.
(In reply to Jeff Griffiths (:canuckistani) from comment #13)
> IMO we should WONTFIX, simply because it makes the dev tools much less
> discoverable. We need this UI hook in this particular place so that we do
> not violate the expectations of web developers. Happy to discuss if Stephen
> feels differently.

I agree. We are trying to keep our menus trimmed but this is worth the placement.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WONTFIX

Updated

4 years ago
Duplicate of this bug: 934497

Updated

3 years ago
Blocks: 971597
Duplicate of this bug: 1175380
(Reporter)

Updated

a year ago
Whiteboard: [mozfr-community]
You need to log in before you can comment on or make changes to this bug.