Last Comment Bug 691478 - JavaScript strict warning: resource:///modules/HUDService.jsm, line 5012: reference to undefined property this.lastInputValue
: JavaScript strict warning: resource:///modules/HUDService.jsm, line 5012: ref...
Status: RESOLVED FIXED
:
Product: Firefox
Classification: Client Software
Component: Developer Tools (show other bugs)
: Trunk
: All All
: P2 normal (vote)
: Firefox 12
Assigned To: Michael Ratcliffe [:miker] [:mratcliffe]
:
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-10-03 13:12 PDT by Richard Newman [:rnewman]
Modified: 2012-01-05 01:46 PST (History)
4 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Ridiculously simple patch (924 bytes, patch)
2011-12-21 01:58 PST, Michael Ratcliffe [:miker] [:mratcliffe]
dcamp: review+
Details | Diff | Splinter Review

Description Richard Newman [:rnewman] 2011-10-03 13:12:18 PDT
Strict mode warning dumped to stdout.

JavaScript strict warning: resource:///modules/HUDService.jsm, line 5012: reference to undefined property this.lastInputValue
Comment 1 Dave Camp (:dcamp) 2011-10-27 08:44:03 PDT
We're doing developer tool prioritization, filter on 'brontozaur'
to ignore the spam.
Comment 2 Michael Ratcliffe [:miker] [:mratcliffe] 2011-12-20 04:25:50 PST
I am not able to reproduce this. Richard, what do we need to do to reproduce this bug?
Comment 3 Richard Newman [:rnewman] 2011-12-20 14:49:44 PST
(In reply to Michael Ratcliffe from comment #2)
> I am not able to reproduce this. Richard, what do we need to do to reproduce
> this bug?

As I recall, this was just launching an m-c build with a testing profile. I periodically scan through the console output and file bugs for all the warnings and errors I find.

I can't reproduce this bug in a current build, but that doesn't mean it isn't still lurking. I assume this is the culprit:

  http://mxr.mozilla.org/mozilla-central/source/browser/devtools/webconsole/HUDService.jsm#5174

A little bit of code reading might reveal a timing bug here.
Comment 4 Michael Ratcliffe [:miker] [:mratcliffe] 2011-12-21 01:58:17 PST
Created attachment 583429 [details] [diff] [review]
Ridiculously simple patch

Ridiculously simple patch.

inputEventHandler() could theoretically be called before setInputValue(). Defining this.lastInputValue as "" fixes this.
Comment 5 Rob Campbell [:rc] (:robcee) 2012-01-04 06:10:58 PST
https://hg.mozilla.org/integration/fx-team/rev/93e89c2fd096
Comment 6 Tim Taubert [:ttaubert] 2012-01-05 01:46:20 PST
https://hg.mozilla.org/mozilla-central/rev/93e89c2fd096

Note You need to log in before you can comment on or make changes to this bug.