If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Crash [@ TOutputGLSLBase::writeTriplet]

RESOLVED DUPLICATE of bug 705735

Status

()

Core
Graphics
--
critical
RESOLVED DUPLICATE of bug 705735
6 years ago
6 years ago

People

(Reporter: nhirata, Unassigned)

Tracking

({crash, topcrash})

Trunk
ARM
Android
crash, topcrash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [mobile-crash], [native-crash], str-wanted, crash signature)

This bug was filed from the Socorro interface and is 
report bp-c7dbc554-abb2-4e13-9ade-a3c722111002 .
============================================================= 

Frame 	Module 	Signature [Expand] 	Source
0 	libmozutils.so 	arena_dalloc 	memory/jemalloc/jemalloc.c:4306
1 	libmozutils.so 	__wrap_free 	memory/jemalloc/jemalloc.c:6260
2 	libmozalloc.so 	moz_free 	memory/mozalloc/mozalloc.cpp:98
3 	libxul.so 	std::__node_alloc::deallocate 	mozalloc.h:253
4 	libxul.so 	std::priv::_String_base<char, std::allocator<char> >::_M_deallocate_block 	_string_base.h:102
5 	libxul.so 	std::basic_string<char, std::char_traits<char>, std::allocator<char> >::_M_append 	_string_base.h:160
6 	libxul.so 	TInfoSinkBase::operator<< 	gfx/angle/src/compiler/InfoSink.h:58
7 	libxul.so 	TOutputGLSLBase::writeTriplet 	gfx/angle/src/compiler/OutputGLSLBase.cpp:91
8 	libxul.so 	TOutputGLSLBase::visitBinary 	gfx/angle/src/compiler/OutputGLSLBase.cpp:212
9 	libxul.so 	TIntermBinary::traverse 	gfx/angle/src/compiler/IntermTraverse.cpp:84
10 	libxul.so 	TOutputGLSLBase::visitAggregate 	gfx/angle/src/compiler/OutputGLSLBase.cpp:456
11 	libxul.so 	TIntermAggregate::traverse 	gfx/angle/src/compiler/IntermTraverse.cpp:135
12 	libxul.so 	TOutputGLSLBase::visitCodeBlock 	gfx/angle/src/compiler/OutputGLSLBase.cpp:713
13 	libxul.so 	TOutputGLSLBase::visitAggregate 	gfx/angle/src/compiler/intermediate.h:547
14 	libxul.so 	TIntermAggregate::traverse 	gfx/angle/src/compiler/IntermTraverse.cpp:135
15 	libxul.so 	TOutputGLSLBase::visitAggregate 	gfx/angle/src/compiler/OutputGLSLBase.cpp:456
16 	libxul.so 	TIntermAggregate::traverse 	gfx/angle/src/compiler/IntermTraverse.cpp:135
17 	libxul.so 	TranslatorESSL::translate 	gfx/angle/src/compiler/OutputGLSLBase.h:17
18 	libxul.so 	TCompiler::compile 	gfx/angle/src/compiler/Compiler.cpp:182
19 	libxul.so 	ShCompile 	gfx/angle/src/compiler/ShaderLang.cpp:169
20 	libxul.so 	mozilla::WebGLContext::CompileShader 	content/canvas/src/WebGLContextGL.cpp:4043
21 	libxul.so 	nsIDOMWebGLRenderingContext_CompileShader 	obj-firefox/js/src/xpconnect/src/dom_quickstubs.cpp:29960
22 	libxul.so 	js::Interpret 	js/src/jscntxtinlines.h:296
23 	libxul.so 	js::RunScript 	js/src/jsinterp.cpp:585
24 	libxul.so 	js::Invoke 	js/src/vm/Stack.h:1000
25 	libxul.so 	JS_CallFunctionValue 	js/src/jscntxt.h:1321
26 	libxul.so 	nsJSContext::CallEventHandler 	dom/base/nsJSEnvironment.cpp:1946
27 	libxul.so 	nsJSEventListener::HandleEvent 	dom/src/events/nsJSEventListener.cpp:213
28 	libxul.so 	nsEventListenerManager::HandleEventSubType 	content/events/src/nsEventListenerManager.cpp:740
29 	libxul.so 	nsEventListenerManager::HandleEventInternal 	content/events/src/nsEventListenerManager.cpp:790
30 	libxul.so 	nsEventTargetChainItem::HandleEvent 	content/events/src/nsEventListenerManager.h:160
31 	libxul.so 	nsEventTargetChainItem::HandleEventTargetChain 	content/events/src/nsEventDispatcher.cpp:346
32 	libxul.so 	nsEventDispatcher::Dispatch 	content/events/src/nsEventDispatcher.cpp:674
33 	libxul.so 	DocumentViewerImpl::LoadComplete 	layout/base/nsDocumentViewer.cpp:1068
34 	libxul.so 	nsDocShell::EndPageLoad 	docshell/base/nsDocShell.cpp:6162
35 	libxul.so 	nsDocShell::OnStateChange 	nsCOMPtr.h:515
36 	libxul.so 	nsDocLoader::DoFireOnStateChange 	uriloader/base/nsDocLoader.cpp:1367
37 	libxul.so 	nsDocLoader::doStopDocumentLoad 	uriloader/base/nsDocLoader.cpp:962
38 	libxul.so 	nsDocLoader::DocLoaderIsEmpty 	nsAutoPtr.h:1036
39 	libxul.so 	nsDocLoader::OnStopRequest 	uriloader/base/nsDocLoader.cpp:740
40 	libxul.so 	nsLoadGroup::RemoveRequest 	netwerk/base/src/nsLoadGroup.cpp:734
41 	libxul.so 	nsDocument::DoUnblockOnload 	nsCOMPtr.h:515
42 	libxul.so 	nsDocument::UnblockOnload 	content/base/src/nsDocument.cpp:7153
43 	libxul.so 	nsDocument::DispatchContentLoadedEvents 	nsCOMPtr.h:515
44 	libxul.so 	nsRunnableMethodImpl<void , true>::Run 	nsThreadUtils.h:347
45 	libxul.so 	nsThread::ProcessNextEvent 	xpcom/threads/nsThread.cpp:631
46 	libxul.so 	NS_ProcessNextEvent_P 	obj-firefox/xpcom/build/nsThreadUtils.cpp:245
47 	libxul.so 	mozilla::ipc::MessagePump::Run 	ipc/glue/MessagePump.cpp:111
48 	libxul.so 	mozilla::ipc::MessagePumpForChildProcess::Run 	ipc/glue/MessagePump.cpp:230
49 	libxul.so 	MessageLoop::RunInternal 	ipc/chromium/src/base/message_loop.cc:209
50 	libxul.so 	MessageLoop::Run 	ipc/chromium/src/base/message_loop.cc:487
51 	libxul.so 	nsBaseAppShell::Run 	widget/src/xpwidgets/nsBaseAppShell.cpp:191
52 	libxul.so 	XRE_RunAppShell 	toolkit/xre/nsEmbedFunctions.cpp:677
53 	libxul.so 	mozilla::ipc::MessagePumpForChildProcess::Run 	ipc/glue/MessagePump.cpp:222
54 	libxul.so 	MessageLoop::RunInternal 	ipc/chromium/src/base/message_loop.cc:209
55 	libxul.so 	MessageLoop::Run 	ipc/chromium/src/base/message_loop.cc:487
56 	libxul.so 	XRE_InitChildProcess 	nsAutoPtr.h:155
57 	libmozutils.so 	ChildProcessInit 	other-licenses/android/APKOpen.cpp:790
58 	plugin-container 	main 	ipc/app/MozillaRuntimeMainAndroid.cpp:69
59 	libc.so 	__libc_init 	
60 		@0xffffffe3

More Reports:
https://crash-stats.mozilla.com/report/list?range_value=7&range_unit=days&date=2011-10-03%2013%3A00%3A00&signature=arena_dalloc%20|%20__wrap_free%20|%20moz_free%20|%20std%3A%3A__node_alloc%3A%3Adeallocate&version=Fennec%3A10.0a1

Possible one off from Bug 687554?  Need to investigate

#7 in top 10 bugs for 10.0a1
Crash Signature: [@ TOutputGLSLBase::writeTriplet] → [@ TOutputGLSLBase::writeTriplet] [@ pthread_mutex_lock ]
Keywords: topcrash
Whiteboard: [mobile-crash] → [mobile-crash], [native-crash], str-wanted

Updated

6 years ago
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 705735
You need to log in before you can comment on or make changes to this bug.