Last Comment Bug 691560 - crash [@ mozilla::AndroidBridge::InitCamera]
: crash [@ mozilla::AndroidBridge::InitCamera]
Status: VERIFIED FIXED
[testday-20111007]
: crash, regression
Product: Fennec Graveyard
Classification: Graveyard
Component: General (show other bugs)
: Firefox 9
: ARM Android
: -- critical (vote)
: Firefox 10
Assigned To: [:fabrice] Fabrice Desré
:
:
Mentors:
Depends on:
Blocks: 659188
  Show dependency treegraph
 
Reported: 2011-10-03 15:59 PDT by Naoki Hirata :nhirata (please use needinfo instead of cc)
Modified: 2013-12-10 10:00 PST (History)
7 users (show)
See Also:
QA Whiteboard:
Iteration: ---
Points: ---


Attachments
fix (1.17 KB, patch)
2011-10-04 11:02 PDT, [:fabrice] Fabrice Desré
blassey.bugs: review+
asa: approval‑mozilla‑aurora+
Details | Diff | Splinter Review

Description Naoki Hirata :nhirata (please use needinfo instead of cc) 2011-10-03 15:59:37 PDT
This bug was filed from the Socorro interface and is 
report bp-4f1a85a4-cfb7-4089-bde0-8a9812111003 .
============================================================= 
Frame 	Module 	Signature [Expand] 	Source
0 	libxul.so 	mozilla::AndroidBridge::InitCamera 	widget/src/android/AndroidBridge.cpp:1072
1 	libxul.so 	mozilla::net::CameraStreamImpl::Init 	netwerk/protocol/device/CameraStreamImpl.cpp:120
2 	libxul.so 	AndroidCameraInputStream::Init 	netwerk/protocol/device/AndroidCaptureProvider.cpp:84
3 	libxul.so 	AndroidCaptureProvider::Init 	netwerk/protocol/device/AndroidCaptureProvider.cpp:316
4 	libxul.so 	nsDeviceChannel::OpenContentStream 	nsAutoPtr.h:907
5 	libxul.so 	nsBaseChannel::BeginPumpingData 	netwerk/base/src/nsBaseChannel.cpp:241
6 	libxul.so 	nsBaseChannel::AsyncOpen 	netwerk/base/src/nsBaseChannel.cpp:610
7 	libxul.so 	nsHTMLMediaElement::LoadResource 	content/html/content/src/nsHTMLMediaElement.cpp:991
8 	libxul.so 	nsHTMLMediaElement::SelectResource 	content/html/content/src/nsHTMLMediaElement.cpp:656
9 	libxul.so 	nsSyncSection::Run 	content/html/content/src/nsHTMLMediaElement.cpp:558
10 	libxul.so 	nsBaseAppShell::RunSyncSections 	nsVoidArray.h:63
11 	libxul.so 	nsBaseAppShell::OnProcessNextEvent 	widget/src/xpwidgets/nsBaseAppShell.cpp:343
12 	libxul.so 	mozilla::dom::ContentParent::OnProcessNextEvent 	dom/ipc/ContentParent.cpp:1111
13 	libxul.so 	nsThread::ProcessNextEvent 	nsTArray.h:169
14 	libxul.so 	NS_InvokeByIndex_P 	xpcom/reflect/xptcall/src/md/unix/xptcinvoke_arm.cpp:195
15 	libxul.so 	XPCWrappedNative::CallMethod 	js/src/xpconnect/src/xpcwrappednative.cpp:3147
16 	libxul.so 	XPC_WN_CallMethod 	js/src/xpconnect/src/xpcwrappednativejsops.cpp:1629
17 	libxul.so 	js::Interpret 	js/src/jscntxtinlines.h:301
18 	libxul.so 	js::RunScript 	js/src/jsinterp.cpp:614
19 	libxul.so 	js::Invoke 	js/src/vm/Stack.h:1000
20 	libxul.so 	JS_CallFunctionValue 	js/src/jscntxt.h:1306
21 	libxul.so 	nsFrameMessageManager::ReceiveMessage 	content/base/src/nsFrameMessageManager.cpp:494
22 	libxul.so 	nsFrameMessageManager::ReceiveMessage 	content/base/src/nsFrameMessageManager.cpp:508
23 	libxul.so 	mozilla::dom::ContentParent::RecvSyncMessage 	dom/ipc/ContentParent.cpp:1158
24 	libxul.so 	mozilla::dom::PContentParent::OnMessageReceived 	obj-firefox/ipc/ipdl/PContentParent.cpp:1575
25 	libxul.so 	mozilla::ipc::SyncChannel::OnDispatchMessage 	ipc/glue/SyncChannel.cpp:175
26 	libxul.so 	mozilla::ipc::RPCChannel::OnMaybeDequeueOne 	ipc/glue/RPCChannel.cpp:431
27 	libxul.so 	RunnableMethod<mozilla::ipc::RPCChannel, bool , Tuple0>::Run 	ipc/chromium/src/base/task.h:308
28 	libxul.so 	mozilla::ipc::RPCChannel::DequeueTask::Run 	RPCChannel.h:487
29 	libxul.so 	MessageLoop::RunTask 	ipc/chromium/src/base/message_loop.cc:319
30 	libxul.so 	MessageLoop::DeferOrRunPendingTask 	ipc/chromium/src/base/message_loop.cc:329
31 	libxul.so 	MessageLoop::DoWork 	ipc/chromium/src/base/message_loop.cc:426
32 	libxul.so 	mozilla::ipc::DoWorkRunnable::Run 	ipc/glue/MessagePump.cpp:71
33 	libxul.so 	nsThread::ProcessNextEvent 	xpcom/threads/nsThread.cpp:631
34 	libxul.so 	NS_ProcessNextEvent_P 	obj-firefox/xpcom/build/nsThreadUtils.cpp:245
35 	libxul.so 	mozilla::ipc::MessagePump::Run 	ipc/glue/MessagePump.cpp:134
36 	libxul.so 	MessageLoop::RunInternal 	ipc/chromium/src/base/message_loop.cc:209
37 	libxul.so 	MessageLoop::Run 	ipc/chromium/src/base/message_loop.cc:487
38 	libxul.so 	nsBaseAppShell::Run 	widget/src/xpwidgets/nsBaseAppShell.cpp:191
39 	libxul.so 	nsAppStartup::Run 	toolkit/components/startup/nsAppStartup.cpp:229
40 	libxul.so 	XRE_main 	toolkit/xre/nsAppRunner.cpp:3558
41 	libxul.so 	Java_org_mozilla_gecko_GeckoAppShell_nativeRun 	toolkit/xre/nsAndroidStartup.cpp:132
42 	libmozutils.so 	Java_org_mozilla_gecko_GeckoAppShell_nativeRun 	other-licenses/android/APKOpen.cpp:232
43 	libdvm.so 	dvmPlatformInvoke 	
44 	libdvm.so 	dvmCallJNIMethod_general 	
45 	libdvm.so 	dvmResolveNativeMethod 	
46 	libdvm.so 	dvmAsmSisterStart 	
47 	libdvm.so 	dvmMterpStd 	
48 	libdvm.so 	dvmInterpret 	
49 	libdvm.so 	dvmCallMethodV 	
50 	libdvm.so 	dvmCallMethod 	
51 	libdvm.so 	dvmDetachCurrentThread 	
52 	libc.so 	__thread_entry 	
53 	libc.so 	pthread_create

Notes: 
HTC Desire, samsung GT-I9000 on builds 20111003042017, 20110930042012, 20111001042013

More Crashes : https://crash-stats.mozilla.com/report/list?range_value=7&range_unit=days&date=2011-10-03%2013%3A00%3A00&signature=mozilla%3A%3AAndroidBridge%3A%3AInitCamera&version=Fennec%3A9.0a2
Comment 1 [:fabrice] Fabrice Desré 2011-10-04 11:02:45 PDT
Created attachment 564608 [details] [diff] [review]
fix

The crash was due to the use of a level >= 9 API on phones that don't support it.
Comment 2 [:fabrice] Fabrice Desré 2011-10-04 11:25:33 PDT
pushed:
https://hg.mozilla.org/integration/mozilla-inbound/rev/b856eb9c2f9d
Comment 3 [:fabrice] Fabrice Desré 2011-10-04 12:18:53 PDT
Comment on attachment 564608 [details] [diff] [review]
fix

Asking approval for Aurora, since it fixes a crash and enables camera support for more devices. The risk of this patch is very low.
Comment 4 Marco Bonardo [::mak] 2011-10-05 05:04:44 PDT
https://hg.mozilla.org/mozilla-central/rev/b856eb9c2f9d
Comment 5 John Hammink 2011-10-05 15:54:19 PDT
Can still reproduce on my device, Nightly build from October 5, 2011
Comment 6 Matt Brubeck (:mbrubeck) 2011-10-05 16:14:52 PDT
This fix is not in the October 5 nightly.  It should be in tomorrow's nightly build.
Comment 7 Cristian Nicolae (:xti) 2011-10-07 04:21:10 PDT
This issue is still reproducing on the latest Aurora build: https://crash-stats.mozilla.com/report/index/bp-23597e1c-5bc7-43ac-854d-98dba2111007

--
Mozilla/5.0 (Android;Linux armv7l;rv:9.0a2)Gecko/20111006
Firefox/9.0a2 Fennec/9.0a2
Device: Samsung Galaxy S
OS: Android 2.2
Comment 8 Mark Finkle (:mfinkle) (use needinfo?) 2011-10-07 05:33:59 PDT
(In reply to Cristian Nicolae (:xti) from comment #7)
> This issue is still reproducing on the latest Aurora build:
> https://crash-stats.mozilla.com/report/index/bp-23597e1c-5bc7-43ac-854d-
> 98dba2111007

The patch has not landed on aurora yet
Comment 9 [:fabrice] Fabrice Desré 2011-10-07 10:21:48 PDT
pushed to aurora:
https://hg.mozilla.org/releases/mozilla-aurora/rev/8b33f4aae60d
Comment 10 Cristian Nicolae (:xti) 2011-12-29 06:45:20 PST
Verified fixed on:
Mozilla/5.0 (Android;Linux armv7l;rv:10.0)Gecko/20111228
Firefox/10.0 Fennec/10.0
Devices: Samsung Galaxy S
OS: Android 2.2

Note You need to log in before you can comment on or make changes to this bug.