Last Comment Bug 691579 - Get rid of broken multiple homepage code in startPage()
: Get rid of broken multiple homepage code in startPage()
Status: RESOLVED FIXED
:
Product: Firefox
Classification: Client Software
Component: General (show other bugs)
: Trunk
: All All
: -- normal (vote)
: Firefox 10
Assigned To: :Margaret Leibovic
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-10-03 16:33 PDT by :Margaret Leibovic
Modified: 2011-10-04 09:36 PDT (History)
1 user (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
patch (2.19 KB, patch)
2011-10-03 16:33 PDT, :Margaret Leibovic
gavin.sharp: review+
Details | Diff | Review

Description :Margaret Leibovic 2011-10-03 16:33:46 PDT
Created attachment 564390 [details] [diff] [review]
patch

We don't use the browser.startup.homepage.count pref in the UI, and if someone did happen to set it manually, it wouldn't work because this code separates homepages with "\n", when consumers expect them to be separated with "|".
Comment 2 Rob Campbell [:rc] (:robcee) 2011-10-04 05:27:55 PDT
https://hg.mozilla.org/mozilla-central/rev/362872311015

Note You need to log in before you can comment on or make changes to this bug.