Last Comment Bug 691603 - IM: Assertion failure: GlobalIonContext, at ion/Ion.cpp:126
: IM: Assertion failure: GlobalIonContext, at ion/Ion.cpp:126
Status: RESOLVED FIXED
: assertion, testcase
Product: Core
Classification: Components
Component: JavaScript Engine (show other bugs)
: Other Branch
: x86_64 Linux
: -- major (vote)
: ---
Assigned To: David Anderson [:dvander]
:
Mentors:
: 685377 (view as bug list)
Depends on:
Blocks: langfuzz
  Show dependency treegraph
 
Reported: 2011-10-03 17:19 PDT by Christian Holler (:decoder)
Modified: 2013-01-14 08:17 PST (History)
5 users (show)
choller: in‑testsuite+
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
fix (3.12 KB, patch)
2011-10-11 13:45 PDT, David Anderson [:dvander]
cdleary: review+
Details | Diff | Review

Description Christian Holler (:decoder) 2011-10-03 17:19:45 PDT
The following testcase asserts on ionmonkey revision acf3c1fb7c94 (run with --ion-eager), tested on 64 bit:


function bitsinbyte(b) {
    while(m<0x100) {    }
}
function TimeFunc(func) {
    for(var y=0; y<256; y++) func(y);
}
function nestedExit2() {
    TimeFunc(bitsinbyte);
}
assertEq(nestedExit2(), "ok");
Comment 1 David Anderson [:dvander] 2011-10-11 13:45:59 PDT
Created attachment 566328 [details] [diff] [review]
fix

Another test failure.
Comment 2 Chris Leary [:cdleary] (not checking bugmail) 2011-10-18 14:52:38 PDT
dvander explained that it was the bailout thunk-to-interpreter that was handling the false value returned from the interpreter and thus was calling into js::ion::HandleException.
Comment 3 David Anderson [:dvander] 2011-10-24 18:50:51 PDT
http://hg.mozilla.org/projects/ionmonkey/rev/71e491bda9a6
Comment 4 David Anderson [:dvander] 2011-10-24 18:55:23 PDT
*** Bug 685377 has been marked as a duplicate of this bug. ***
Comment 5 Christian Holler (:decoder) 2013-01-14 08:17:34 PST
A testcase for this bug was automatically identified at js/src/jit-test/tests/ion/bug691603.js.

Note You need to log in before you can comment on or make changes to this bug.