Last Comment Bug 691689 - Telemetry revise advice about re-enabling; point user to Firefox KB & toolbar/firefox button menu instead of about:config
: Telemetry revise advice about re-enabling; point user to Firefox KB & toolbar...
Status: RESOLVED DUPLICATE of bug 661881
: uiwanted
Product: Toolkit
Classification: Components
Component: Telemetry (show other bugs)
: Trunk
: All All
: -- normal (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-10-04 01:11 PDT by John Hesling [:John99]
Modified: 2012-09-12 01:08 PDT (History)
2 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments

Description John Hesling [:John99] 2011-10-04 01:11:08 PDT
Product: toolkit
Component: Telemetry
Keyword: uiwanted 

When Telemetry is disabled the about:telemetry screen first line of display is:
> Please set toolkit.telemetry.enabled to true in about:config
 (<i>about:config</i> is underlined and in blue)


Users may expect about:config to be an active link as it is shown as blue underlined text.
It would be more user friendly to use the UI menu "Options" & or explain the use of about protocols & about:config.

This could be explained in the text, as a prior suggestion and probably explained by adding a link to the Firefox kb article https://support.mozilla.com/en-US/kb/Options%20window%20-%20Advanced%20panel?as=u#w_general-tab

One suggestion for the sort of revised text I envisage
> If you wish to re-enable sending telemetry data please use:
> about:config (advanced users)
> or the Options window  https://support.mozilla.com/en-US/kb/Options%20window%20-%20Advanced%20panel?as=u#w_general-tab
Comment 1 Nathan Froyd [:froydnj] 2012-09-12 01:08:54 PDT
about:telemetry isn't an official thing, but when it becomes so, it should certainly have something like this.

*** This bug has been marked as a duplicate of bug 661881 ***

Note You need to log in before you can comment on or make changes to this bug.