Performance with fixed background images

RESOLVED DUPLICATE of bug 90198

Status

()

Core
Layout: View Rendering
RESOLVED DUPLICATE of bug 90198
18 years ago
17 years ago

People

(Reporter: Pierre Saslawsky, Assigned: Kevin McCluskey (gone))

Tracking

({perf})

Trunk
Future
PowerPC
Mac System 8.5
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
This bug is extracted from bug 68821.

Scrolling is very slow when there is a fixed background image.  As I wrote in bug 
68821 [2001-02-15 04:15], the problem is that a fixed background causes the frame 
to set the NS_VIEW_PUBLIC_FLAG_DONT_BITBLT on the view, which means that the view 
is entirely redrawn everytime we scroll.  We should instead redraw only the 
portion of the page that contains the image.

See the testcase I attached to the other bug:
http://bugzilla.mozilla.org/showattachment.cgi?attach_id=25333

For the bug to be obvious, the page should not be too small.
Currently, the view manager isn't told which part of the view is non-blittable.

To track that, we would need an extra rectangle field in each view (or maybe 
just a pointer since we won't need it often), and we'd have to change the view 
manager interface so that layout tells us the non-blittable rectangle. This 
information would have to be updated as the image loads and its size 
information becomes available.

In other words, this would be a real pain.
(Assignee)

Comment 2

18 years ago
Setting target milestone to 1.0.1
Target Milestone: --- → mozilla1.0.1
(Assignee)

Comment 3

18 years ago
Clearing milestone.
Target Milestone: mozilla1.0.1 → ---
(Assignee)

Comment 4

18 years ago
Set milestone to future
Status: NEW → ASSIGNED
Target Milestone: --- → Future

Comment 5

18 years ago
Does the performance drop off dramatically with CPU speed?  On 500 Mhz there is
no perceptible slowdown on the referenced page.

Updated

18 years ago
Keywords: perf

Comment 6

17 years ago
Can't reproduce this with Mozilla/5.0 (Windows; U; WinNT4.0; en-US; 0.8.1)
Gecko/20010412

Scrolling of the attachment mentioned is really fast thanks to the new imglib.

Comment 7

17 years ago
Additional test pages:
http://www.physics.hmc.edu/courses/p028/
http://www.w3.org/TR/html401/

The physics lab page scrolls slowly for me on Win98 using Mozilla 2001 042908.

Comment 8

17 years ago
I see visible slowdown on Linux, K6-2 350

Comment 9

17 years ago
less but still visible slowdown on NT4, Celeron 450

Comment 10

17 years ago
bigger slowdown on linux was actually caused by bigger screen resolution

Comment 11

17 years ago
see this on linux,too
sould be platform all -> all

Comment 12

17 years ago
I think this is a bad dupe of 90198 (Bugzilla Bug 90198 scrolling very slow
(fixed background)), but that bug is assigned to Kevin too! (although I suspect
he doesn't know that). And btw like people say above, this is an ALL/ALL bug,
really.

Comment 13

17 years ago
Marking dup per xan's comment.

*** This bug has been marked as a duplicate of 90198 ***
Status: ASSIGNED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.