Note: There are a few cases of duplicates in user autocompletion which are being worked on.

dragging selected URLs from location bar to textarea doesn't prepend the http:// part

RESOLVED DUPLICATE of bug 670587

Status

()

Firefox
Location Bar
RESOLVED DUPLICATE of bug 670587
6 years ago
3 years ago

People

(Reporter: Loic, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:7.0.1) Gecko/20100101 Firefox/7.0.1
Build ID: 20110928134238

Steps to reproduce:

Steps to reproduce:
1: Go to about:config.
2: Make sure that the setting browser.urlbar.trimURLs is set to true (so that http:// isn't shown in the Firefox location bar).
3: Go to any http:// page containing a text area (say, the "post a reply" section on this page when logged in).
4: Double-click on the URL in the Firefox location bar so that the complete URL is selected.
5: While pointing at the URL in the location bar, press down the left mouse button.
6: Move the mouse cursor to the "post a reply" text area.
7: Release the left mouse button.



Actual results:

The URL is now pasted into the text area without the leading http:// part.


Expected results:

If browser.urlbar.trimURLs is set to false, the complete URL (including http://) is pasted into the text area.
SeaMonkey always seems to display the http:// part (no browser.urlbar.trimURLs appears in my about:config) and so is unaffected by this bug.
(Reporter)

Updated

6 years ago
OS: Windows 7 → All
Hardware: x86_64 → All

Updated

6 years ago
Blocks: 665580, 666964
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: URLs are pasted into textarea without the leading http:// part → dragging selected URLs from location bar to textarea doesn't prepend the http:// part
Version: 7 Branch → Trunk

Comment 1

6 years ago
Just some clarification: the text seems to be a copy of some text I wrote on the Mozillazine forums, and some of the wordings (e.g. "this page") may look a bit confusing if read out of context. I didn't report any bug myself since it looked like a dupe of bug 670587 (which is about dragging and dropping into text areas in external programs).
A patch for bug 670587 would fix this - the drag and drop *target* is mostly irrelevant.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 670587

Updated

6 years ago
No longer blocks: 665580

Updated

6 years ago
No longer blocks: 666964
You need to log in before you can comment on or make changes to this bug.