Closed Bug 691726 Opened 8 years ago Closed 8 years ago

window.moveTo and window.resizeTo not updating window

Categories

(Firefox :: General, defect, major)

7 Branch
x86
macOS
defect
Not set
major

Tracking

()

RESOLVED DUPLICATE of bug 691693

People

(Reporter: mattias, Unassigned)

Details

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_6_8) AppleWebKit/534.50 (KHTML, like Gecko) Version/5.1 Safari/534.50

Steps to reproduce:

Called window.moveTo and window.resizeTo on one open window. In the advanced javascripts settings the "Move or resize existing windows" was checked. 


Actual results:

Nothing. Did not work in 8.0b1 either.


Expected results:

The windows size and position should have changed.
Severity: normal → major
How did you call window.moveTo? From a script run in a web page or some other way?
The call was made from a script on a web page. The page that was running the script was the same that had open the window previously. Tried with the call initiated in 2 different ways: from setInterval and from a button click.
This is intended.
Blocks: 565541
Status: UNCONFIRMED → RESOLVED
Closed: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 689974
Are you sure j.j.?
I think script from a page that originally opened the window is supposed to still be able to resize the window it created.

Mattias we would need to see the code (or URL) how you do it, to be sure about the relation of the script page to the window.
Mattias, do you have Firebug installed?
If yes, possible dupe of Bug 691693.
(In reply to aceman from comment #4)
> Are you sure j.j.?
I didn't bother much with details. Feel free to change it if appropriate.
I tried with firebug disabled and it solved the problem.
Duplicate of bug: 691693
Great. Per the comments in bug 565541 it will be solved in Firebug 1.9a4 soon.
No longer blocks: 565541
You need to log in before you can comment on or make changes to this bug.