Closed Bug 691753 Opened 8 years ago Closed 8 years ago

w32-ix-slave37, linux-ix-slave13 - no Mercurial repository here

Categories

(Release Engineering :: General, defect)

x86
Windows 7
defect
Not set

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 693202

People

(Reporter: joey, Assigned: joey)

References

Details

(Whiteboard: [tryserver])

A win64 with a similar problem had filesystem issues last week.  Still tracking down the source on this one.

https://tbpl.mozilla.org/?rev=a2762135831e

abort: There is no Mercurial repository here (.hg not found)!
  ** try jobs should fail immediately on this type of problem

builder: mozilla-central-win32
slave: w32-ix-slave37
starttime: 1317415302.58
results: warnings (1)
buildid: 20110930134132
builduid: 94e59f3fe0fd4f7681670ade1b8a0d16
revision: a2762135831e

command: START
command: hg pull -r a2762135831ef473ddc590cceaa63c1fffeebab9 http://hg.mozilla.org/mozilla-central
command: cwd: e:\builds\moz2_slave\m-cen-w32\build
command: output:
abort: There is no Mercurial repository here (.hg not found)!
command: END (0.16s elapsed)
Assignee: nobody → joey
Whiteboard: [tryserver]
Error pulling changes into e:\builds\moz2_slave\m-cen-w32\build from http://hg.mozilla.org/mozilla-central; clobbering.

Need to enable debug mode or reporting exceptions in the call to hg.py pull to figure out why hg.exe failed.
See Also: → 691467
Here's another one on a different slave.  (I can open a separate bug for this if you want.)

https://tbpl.mozilla.org/php/getParsedLog.php?id=6834311&tree=Mozilla-Beta

builder: mozilla-beta-linux-debug
slave: linux-ix-slave13
starttime: 1318529336.75
results: failure (2)
buildid: 20111013110839
builduid: f49f4166e4c241169f3fb2540c78570a
revision: 41fe33006ba24cf2030dc16379006e264496ec25
Summary: w32-ix-slave37 - no Mercurial repository here → w32-ix-slave37, linux-ix-slave13 - no Mercurial repository here
The "no Mercurial repository here" message isn't the problem here. hgtool detects this case, wipes out the directory, and attempts to re-clone. That then times out, which is bug 693202. Bug 687064 describes a possible fix.

command: START
command: hg pull -r 41fe33006ba24cf2030dc16379006e264496ec25 http://hg.mozilla.org/releases/mozilla-beta
command: cwd: /builds/slave/m-beta-lnx-dbg/build
command: output:
abort: There is no Mercurial repository here (.hg not found)!
command: END (0.08s elapsed)

Error pulling changes into /builds/slave/m-beta-lnx-dbg/build from http://hg.mozilla.org/releases/mozilla-beta; clobbering
Updating shared repo
command: START
command: hg clone -U -r 41fe33006ba24cf2030dc16379006e264496ec25 http://hg.mozilla.org/releases/mozilla-beta /builds/hg-shared/releases/mozilla-beta
command: cwd: /builds/slave/m-beta-lnx-dbg
command: output:

command timed out: 3600 seconds without output, attempting to kill
process killed by signal 9
program finished with exit code -1
elapsedTime=3600.281784
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 693202
Product: mozilla.org → Release Engineering
You need to log in before you can comment on or make changes to this bug.