"Curtain call" DHTML does not work in Mozilla 0.8 .

RESOLVED WORKSFORME

Status

()

Core
DOM: CSS Object Model
RESOLVED WORKSFORME
17 years ago
16 years ago

People

(Reporter: Ronald Buckman, Assigned: Ronald Buckman)

Tracking

({dom1})

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: WORKSFORME?, URL)

(Assignee)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Win98; en-US; 0.8) Gecko/20010215
BuildID:    2001021508

When mousing over a link at this URL which reads "Curtain (some number)" a
colored box is supposed to appear with a message in Latin.  But, it doesn't
appear in Mozilla 0.8 .

Reproducible: Always
Steps to Reproduce:
1. go to: http://www.projectseven.com/curtaincall.htm
2. mouse over a "Curtain" link.

Actual Results:  The link turned white and the underline disappeared.

Expected Results:  In addition to the link turning white and the disappearance
of the underline, a colored box should appear with a message in Latin.

This DHTML demonstration works in IE 5.5 and Opera 5 .
One problem:
onMouseOver event -> popup at mouse position -> onMouseOut event is fired ->
popup immediatly closed
Not sure if that is a bug.

I don't know either, this does work in IE tho, so over to the event guru.
Assignee: jst → joki
The script in question is repeatedly resetting the clip style rule on a div to
create a "curtain" effect:

function curtainDown () {
<!-- Use wt to set speed of down animation higher numbers=faster animation -->
  wt += 30;
  dom.style.clip = 'rect(auto auto ' + wt + ' auto)';
  if (wt < h)
    ver = setTimeout('curtainDown()', 20);
}

It looks like we are not properly redrawing things when the value of clip
changes; if I change what the initial value of wt is (the default is 0), I get
different amounts of the div shown.
OS: Windows 98 → All

Comment 4

17 years ago
Confirmed
Platform: PC
OS: Windows 98
Mozilla Build: 2001022007

Marking NEW.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Hardware: PC → All
Keywords: dom1
Component: DOM Level 1 → DOM Style
Taking QA Contact on all open or unverified DOM Style bugs...
QA Contact: janc → ian

Comment 6

17 years ago
Ian, would you confirm that this is a code bug?  Are you happy that the script 
should work as intended?
Keywords: qawanted
Whiteboard: (py8ieh: need smaller test case)

Comment 7

17 years ago
Ian, over to you.
Assignee: joki → ian
The URI is now 404 compliant (doh).

However, the testcase I made based on the comments works fine:
   http://hixie.ch/tests/adhoc/dom/css/animation/001.xml

Ronald, could you investigate further if you still have access to the page?
Assignee: ian → ron
Keywords: qawanted
Whiteboard: (py8ieh: need smaller test case) → WORKSFORME?
Maybe this is the same as bug 75882, which is wfm now.
(Assignee)

Comment 10

17 years ago
I still am unable to access the original curtain call page.  The box in
http://hixie.ch/tests/adhoc/dom/css/animation/001.xml
would not expand or contract on Mozilla 0.9 for 32 bit Windows.
I guess this is indeed a magically fixed bug now then?
Ian, that testcase is broken.  It sets clip(a b c d) with b < d.

I'm resolving this worksforme; I've played with stuff similar to Ian's testcase
and it all works.  Ronald, if you can get access to the original page and it
still has the problem, please reopen.
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.