Last Comment Bug 691876 - Cannot run Windows jsshell nightlies: mozutil.dll missing
: Cannot run Windows jsshell nightlies: mozutil.dll missing
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: Build Config (show other bugs)
: 7 Branch
: x86_64 Windows 7
: -- normal (vote)
: mozilla11
Assigned To: Jon Buckley
:
Mentors:
: 703381 (view as bug list)
Depends on:
Blocks: 677501
  Show dependency treegraph
 
Reported: 2011-10-04 12:18 PDT by Ben Lerner
Modified: 2011-12-12 11:10 PST (History)
5 users (show)
bzbarsky: in‑testsuite?
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Add mozutils library to jsshell distributable (804 bytes, patch)
2011-11-29 12:32 PST, Jon Buckley
ted: review+
Details | Diff | Splinter Review

Description Ben Lerner 2011-10-04 12:18:42 PDT
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:7.0.1) Gecko/20100101 Firefox/7.0.1
Build ID: 20110928134238

Steps to reproduce:

From bug 686305 comment 2, I tried downloading jsshell-win32.zip and jsshell-win64-x86_64.zip, tried extracting each of them into their own subdirectory, and tried running js.exe.  Neither one worked, and gave the error "the program can't start because mozutils.dll is missing from [my] computer.  Try reinstalling the program to fix this problem.".  What am I missing, and where can I find mozutils.dll if in fact I need it?
Comment 1 Ted Mielczarek [:ted.mielczarek] 2011-10-04 12:29:29 PDT
Needs a packaging fix:
http://mxr.mozilla.org/mozilla-central/source/toolkit/mozapps/installer/packager.mk#92
Comment 2 Mike Hommey [:glandium] 2011-10-04 23:02:49 PDT
There are two options, really: either include mozutils.dll, or stop linking jsshell to it. Do we have a reason to specifically want jsshell to use jemalloc?
Comment 3 Mike Hommey [:glandium] 2011-10-05 00:11:11 PDT
Note: with the landing of bug 414946, the same issue will hit mac, too. Whichever route we take, we can remove the #ifdef in packager.mk, zip will only complain about missing file, but won't fail (iirc its behaviour)
Comment 4 Ted Mielczarek [:ted.mielczarek] 2011-10-05 05:49:36 PDT
I suspect Spidermonkey hackers will in fact want a JS shell linked with jemalloc.
Comment 5 Jon Buckley 2011-11-29 12:32:42 PST
Created attachment 577705 [details] [diff] [review]
Add mozutils library to jsshell distributable

I spoke to David, he's fine with me taking this bug.

This patch simply adds the mozutils library to the archive file containing jsshell.
Comment 6 Jon Buckley 2011-12-07 07:48:35 PST
I built a try-server version at https://tbpl.mozilla.org/?tree=Try&rev=2b9b32464d81 and tested Linux, Mac OS X, and Windows jsshells and they all run without asking for mozutils
Comment 7 Boris Zbarsky [:bz] (TPAC) 2011-12-07 22:35:19 PST
https://hg.mozilla.org/integration/mozilla-inbound/rev/af91b8af10dd
Comment 8 Ed Morley [:emorley] 2011-12-08 08:29:22 PST
https://hg.mozilla.org/mozilla-central/rev/af91b8af10dd
Comment 9 Ryan VanderMeulen [:RyanVM] 2011-12-08 18:57:28 PST
*** Bug 703381 has been marked as a duplicate of this bug. ***
Comment 10 Mozilla RelEng Bot 2011-12-12 11:10:27 PST
Try run for 2b9b32464d81 is complete.
Detailed breakdown of the results available here:
    https://tbpl.mozilla.org/?tree=Try&rev=2b9b32464d81
Results (out of 15 total builds):
    success: 13
    failure: 2
Builds available at http://ftp.mozilla.org/pub/mozilla.org/firefox/try-builds/jon@jbuckley.ca-2b9b32464d81

Note You need to log in before you can comment on or make changes to this bug.