IFRAME doesn't size properly in Table Cells (TD)

VERIFIED DUPLICATE of bug 69191

Status

()

Core
Layout: HTML Frames
VERIFIED DUPLICATE of bug 69191
17 years ago
17 years ago

People

(Reporter: Matt Holder, Assigned: Eric Pollmann)

Tracking

Trunk
x86
Windows 98
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
When you place an IFRAME in a Table cell (TD) where the table, the cell
containing the iframe and the iframe are set to 100% height, the IFRAME appears
as nothing more than a 3D line instead of feeling up the cell.

example code:

<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.0 Transitional//EN">

<html>
<head>
<title>Message</title>
<link rel="STYLESHEET" type="text/css" href="interface.css">
</head>
<body class="ML">
<table width="100%" height="100%" border="0" cellspacing="0"
cellpadding="0"><tr><td>
<table width="100%" cellspacing="0" cellpadding="0" align="center"
class="OutlookHead">
<tr><td><strong>From:</strong> <a HREF="mailto:6XGate
&lt;sixxgate@yahoo.com&gt;">6XGate <sixxgate@yahoo.com></a></td></tr>
<tr><td><strong>Subject:</strong> Test message</td></tr>
<tr><td><strong>Received:</strong> Fri, 16 Feb 2001 12:14:46 -0600</td></tr>
</table></td></tr><tr><td width="100%" height="100%" align="left" valign="top">
<iframe src="www.sixxgate.ath.cx" name="Message" id="Message" width="100%"
height="100%" marginwidth="0" marginheight="0" hspace="0" vspace="0"
scrolling="yes" style="position: relative; clip: auto; vertical-align: top;
visibility: visible; z-index: auto; height: 100%;">
<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.0 Transitional//EN">
<html><head>
<meta content="text/html; charset=iso-8859-1" http-equiv=Content-Type>
<meta content="MSHTML 5.00.3211.1700" name=GENERATOR></head>
<body>
<div><font face=Arial size=2><span class=120211418-16022001>Hello 
there</span></font></div></body></html>
</iframe>
</td></tr></table>
</body>
</html>

Comment 1

17 years ago
sent twice

*** This bug has been marked as a duplicate of 69191 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE
verified
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.