Last Comment Bug 691959 - GCC 4.6 build warning: "nsCSSFrameConstructor.cpp:9934:8: warning: variable 'done' set but not used [-Wunused-but-set-variable]"
: GCC 4.6 build warning: "nsCSSFrameConstructor.cpp:9934:8: warning: variable '...
Status: RESOLVED FIXED
[inbound]
:
Product: Core
Classification: Components
Component: Layout: Text (show other bugs)
: Trunk
: x86_64 Linux
: -- normal (vote)
: mozilla10
Assigned To: Daniel Holbert [:dholbert]
:
:
Mentors:
Depends on:
Blocks: buildwarning
  Show dependency treegraph
 
Reported: 2011-10-04 16:06 PDT by Daniel Holbert [:dholbert]
Modified: 2011-10-09 07:32 PDT (History)
1 user (show)
Ms2ger: in‑testsuite-
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
fix (1.24 KB, patch)
2011-10-04 16:10 PDT, Daniel Holbert [:dholbert]
dbaron: review+
Details | Diff | Splinter Review

Description Daniel Holbert [:dholbert] 2011-10-04 16:06:32 PDT
Filing bug on this GCC 4.6 build warning (the only one I get for nsCSSFrameConstructor.cpp):
> nsCSSFrameConstructor.cpp: In function 'PRInt32 FirstLetterCount(const nsTextFragment*)':
> nsCSSFrameConstructor.cpp:9934:8: warning: variable 'done' set but not used [-Wunused-but-set-variable]

This variable was added in April 1999 in this CVS commit:
http://bonsai.mozilla.org/cvsview2.cgi?diff_mode=context&whitespace_mode=show&root=/cvsroot&subdir=mozilla/layout/base&command=DIFF_FRAMESET&file=nsCSSFrameConstructor.cpp&rev2=1.104&rev1=1.103
with only one use:
> while (aNumFragments && !done) {

That one use was subsequently removed in this commit, in Oct 1999:
http://bonsai.mozilla.org/cvsview2.cgi?diff_mode=context&whitespace_mode=show&root=/cvsroot&subdir=mozilla/layout/base&command=DIFF_FRAMESET&file=nsCSSFrameConstructor.cpp&rev2=1.268&rev1=1.267

and this variable appears to have been unused since then.
Comment 1 Daniel Holbert [:dholbert] 2011-10-04 16:10:00 PDT
Created attachment 564694 [details] [diff] [review]
fix
Comment 2 David Baron :dbaron: ⌚️UTC-7 (busy September 14-25) 2011-10-08 11:54:01 PDT
Comment on attachment 564694 [details] [diff] [review]
fix

r=dbaron
Comment 3 Daniel Holbert [:dholbert] 2011-10-08 14:46:19 PDT
https://hg.mozilla.org/integration/mozilla-inbound/rev/d323beedf560
Comment 4 :Ms2ger (⌚ UTC+1/+2) 2011-10-09 07:32:27 PDT
https://hg.mozilla.org/mozilla-central/rev/d323beedf560

Note You need to log in before you can comment on or make changes to this bug.