Last Comment Bug 691976 - Firefox Crash [@ JS_updateMallocCounter ]
: Firefox Crash [@ JS_updateMallocCounter ]
Status: RESOLVED FIXED
[inbound]
: crash
Product: Core
Classification: Components
Component: Canvas: 2D (show other bugs)
: Trunk
: x86 Windows 7
: -- critical (vote)
: mozilla10
Assigned To: Matt Woodrow (:mattwoodrow) (PTO until 27 June)
:
Mentors:
: 711397 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-10-04 16:46 PDT by Marcia Knous [:marcia - use ni]
Modified: 2011-12-16 08:42 PST (History)
3 users (show)
See Also:
Crash Signature:
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Null check the JS context (1.10 KB, patch)
2011-10-06 17:57 PDT, Matt Woodrow (:mattwoodrow) (PTO until 27 June)
bas: review+
Details | Diff | Review

Description Marcia Knous [:marcia - use ni] 2011-10-04 16:46:58 PDT
Seen while looking at the explosive report for Firefox 7. Bug 656947 was filed a while back and was fixed, but the signature is still showing up in builds ups to 9.0a2.

https://crash-stats.mozilla.com/report/list?signature=JS_updateMallocCounter - Most if not all of the comments mention printing.

Frame 	Module 	Signature [Expand] 	Source
0 	mozjs.dll 	JS_updateMallocCounter 	js/src/jsapi.cpp:2018
1 	xul.dll 	nsCanvasRenderingContext2DAzure::SetDimensions 	content/canvas/src/nsCanvasRenderingContext2DAzure.cpp:1265
2 	xul.dll 	nsHTMLCanvasElement::UpdateContext 	content/html/content/src/nsHTMLCanvasElement.cpp:585
3 	xul.dll 	nsHTMLCanvasElement::GetContext 	content/html/content/src/nsHTMLCanvasElement.cpp:506
4 	xul.dll 	nsHTMLCanvasElement::CopyInnerTo 	content/html/content/src/nsHTMLCanvasElement.cpp:160
5 	xul.dll 	nsHTMLCanvasElement::Clone 	content/html/content/src/nsHTMLCanvasElement.cpp:108
6 	xul.dll 	nsNodeUtils::CloneAndAdopt 	content/base/src/nsNodeUtils.cpp:520
7 	xul.dll 	nsNodeUtils::CloneAndAdopt 	content/base/src/nsNodeUtils.cpp:666
8 	xul.dll 	nsNodeUtils::CloneAndAdopt 	content/base/src/nsNodeUtils.cpp:666
9 	xul.dll 	nsNodeUtils::CloneAndAdopt 	content/base/src/nsNodeUtils.cpp:666
10 	xul.dll 	nsNodeUtils::CloneAndAdopt 	content/base/src/nsNodeUtils.h:301
11 	xul.dll 	nsNodeUtils::CloneNodeImpl 	content/base/src/nsNodeUtils.cpp:439
12 	xul.dll 	nsDocument::CloneNode 	content/base/src/nsDocument.cpp:5778
13 	xul.dll 	nsIDocument::CreateStaticClone 	content/base/src/nsDocument.cpp:7980
14 	xul.dll 	nsPrintObject::Init 	layout/printing/nsPrintObject.cpp:122
15 	xul.dll 	nsPrintEngine::DoCommonPrint 	layout/printing/nsPrintEngine.cpp:543
16 	xul.dll 	nsPrintEngine::CommonPrint 	layout/printing/nsPrintEngine.cpp:444
17 	xul.dll 	nsPrintEngine::Print 	layout/printing/nsPrintEngine.cpp:759
18 	xul.dll 	DocumentViewerImpl::Print 	layout/base/nsDocumentViewer.cpp:3679
19 	xul.dll 	DocumentViewerImpl::LoadComplete 	
20 	xul.dll 	nsDocShell::EndPageLoad 	docshell/base/nsDocShell.cpp:6163
21 	xul.dll 	nsDocShell::OnStateChange 	docshell/base/nsDocShell.cpp:5999
22 	xul.dll 	nsDocLoader::FireOnStateChange 	uriloader/base/nsDocLoader.cpp:1339
23 	xul.dll 	nsDocLoader::doStopDocumentLoad 	uriloader/base/nsDocLoader.cpp:947
24 	xul.dll 	nsDocLoader::DocLoaderIsEmpty 	uriloader/base/nsDocLoader.cpp:823
25 	xul.dll 	nsDocLoader::OnStopRequest 	uriloader/base/nsDocLoader.cpp:707
26 	xul.dll 	nsLoadGroup::RemoveRequest 	netwerk/base/src/nsLoadGroup.cpp:734
27 	xul.dll 	nsBaseChannel::OnStopRequest 	netwerk/base/src/nsBaseChannel.cpp:735
28 	xul.dll 	nsInputStreamPump::OnStateStop 	netwerk/base/src/nsInputStreamPump.cpp:578
29 	xul.dll 	nsInputStreamPump::OnInputStreamReady 	netwerk/base/src/nsInputStreamPump.cpp:403
30 	xul.dll 	nsInputStreamReadyEvent::Run 	xpcom/io/nsStreamUtils.cpp:114
31 	xul.dll 	nsThread::ProcessNextEvent 	xpcom/threads/nsThread.cpp:617
32 	xul.dll 	mozilla::ipc::MessagePump::Run 	ipc/glue/MessagePump.cpp:110
33 	xul.dll 	xul.dll@0xb8ab03 	
34 	xul.dll 	MessageLoop::RunHandler 	ipc/chromium/src/base/message_loop.cc:202
35 	xul.dll 	xul.dll@0x2fc9af 	
36 	xul.dll 	MessageLoop::Run 	ipc/chromium/src/base/message_loop.cc:176
37 	xul.dll 	nsNativeThemeWin::WidgetStateChanged 	widget/src/windows/nsNativeThemeWin.cpp:2242
Comment 1 Matt Woodrow (:mattwoodrow) (PTO until 27 June) 2011-10-06 17:57:38 PDT
Created attachment 565417 [details] [diff] [review]
Null check the JS context

Exactly the same as the normal canvas context.
Comment 2 Matt Woodrow (:mattwoodrow) (PTO until 27 June) 2011-10-25 20:33:04 PDT
https://hg.mozilla.org/integration/mozilla-inbound/rev/0c06915f4465
Comment 3 Ed Morley [:emorley] 2011-10-26 17:09:52 PDT
https://hg.mozilla.org/mozilla-central/rev/0c06915f4465
Comment 4 Boris Zbarsky [:bz] (Out June 25-July 6) 2011-12-16 08:42:40 PST
*** Bug 711397 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.