Enable accessibility in android builds

RESOLVED FIXED

Status

()

Firefox for Android
General
P3
normal
RESOLVED FIXED
6 years ago
6 years ago

People

(Reporter: eeejay, Assigned: eeejay)

Tracking

({access})

unspecified
ARM
Android
access
Points:
---

Firefox Tracking Flags

(firefox11 fixed, fennec11+)

Details

(Whiteboard: [Q4 A11y goal] birch+inbound)

Attachments

(2 attachments, 1 obsolete attachment)

(Assignee)

Description

6 years ago
Created attachment 564896 [details] [diff] [review]
remove android from accessibility blacklist in configure.in

There will be a future need for accessibility to be enabled in Android builds. The TalkToMe[1] extension uses the nsIAccessible interfaces to provide non-visual access to Mobile Firefox. Using the Firefox's accessibility API in this extension allows us to build on top of current core functionality and to not re-invent the wheel in Javascript by using the DOM directly.

1. https://wiki.mozilla.org/Accessibility/TalkToMe

Updated

6 years ago
Priority: -- → P3
(Assignee)

Comment 1

6 years ago
Created attachment 568163 [details]
RSS from 2 minutes in from launching and loading google.com
(Assignee)

Comment 2

6 years ago
(In reply to Eitan Isaacson [:eeejay] from comment #1)
> Created attachment 568163 [details]
> RSS from 2 minutes in from launching and loading google.com

The above is from mozilla central rev 3c684b4b8f68. Cleaned app data, all automated, etc.
Can you note apk size difference?
Whiteboard: [Q4 A11y goal]
(Assignee)

Comment 4

6 years ago
apk size diff is 145 kb
(Assignee)

Updated

6 years ago
Duplicate of this bug: 698438
(Assignee)

Comment 6

6 years ago
Here are the RSS numbers for fennec native (from a week ago).
https://docs.google.com/a/monotonous.org/spreadsheet/pub?hl=en_US&key=0Ar0MGLAdCHJRdG1IN09zaXFoVEFMTzBObnYyd1hKdXc&hl=en_US&gid=2

And a chart:
https://docs.google.com/a/monotonous.org/spreadsheet/pub?hl=en_US&key=0Ar0MGLAdCHJRdG1IN09zaXFoVEFMTzBObnYyd1hKdXc&hl=en_US&gid=4
(Assignee)

Updated

6 years ago
Component: General → General
Product: Fennec → Fennec Native
Version: Trunk → unspecified
(Assignee)

Updated

6 years ago
Attachment #564896 - Flags: review?(doug.turner)

Comment 7

6 years ago
Comment on attachment 564896 [details] [diff] [review]
remove android from accessibility blacklist in configure.in

Review of attachment 564896 [details] [diff] [review]:
-----------------------------------------------------------------

we make software for everyone.
Attachment #564896 - Flags: review?(doug.turner) → review+
(Assignee)

Comment 8

6 years ago
Created attachment 573322 [details] [diff] [review]
remove android from accessibility blacklist in configure.in

Using hg export for patch
Attachment #564896 - Attachment is obsolete: true
(Assignee)

Updated

6 years ago
Whiteboard: [Q4 A11y goal] → [Q4 A11y goal] checkin-needed

Updated

6 years ago
Keywords: access
(Assignee)

Updated

6 years ago
Whiteboard: [Q4 A11y goal] checkin-needed → [Q4 A11y goal] checkin-needed birch
(Assignee)

Updated

6 years ago
Keywords: checkin-needed
Whiteboard: [Q4 A11y goal] checkin-needed birch → [Q4 A11y goal] birch
http://hg.mozilla.org/projects/birch/rev/e2cfd16ab416
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
And inbound
https://hg.mozilla.org/integration/mozilla-inbound/rev/deed0cafecc7
Whiteboard: [Q4 A11y goal] birch → [Q4 A11y goal] birch+inbound
https://hg.mozilla.org/mozilla-central/rev/deed0cafecc7
Assignee: nobody → eitan
Keywords: checkin-needed
tracking-fennec: --- → 11+
status-firefox11: --- → fixed
You need to log in before you can comment on or make changes to this bug.