Status

SeaMonkey
General
--
major
RESOLVED DUPLICATE of bug 53952
18 years ago
14 years ago

People

(Reporter: Kevin Stange, Assigned: asa)

Tracking

({hang})

Trunk
x86
Windows ME

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
I have been experiencing this problem consistently, and cannot solve it.  It
affects my ability launch the browser, though I have never been able to
reproduce it on another computer.  The problem continued following a complete
reformat of my computer, and has occurred in every build of Mozilla that I have
used from M17 through v0.8 and all Netscape builds.

When I attempt to load the browser, it will not display the window.  The browser
loads into memory, but never appears.  It then has to be killed via the "Close
Program" dialog box.  This problem, however, does not occur if Windows has just
been started.  Windows usually must already be running for a while before this
problem begins to appear (I'm reporting this bug with Mozilla and Windows is now
running for about one hour).  I'm guessing that Mozilla has an incompatibility
of some type with a DLL or application that gets loaded during my Windows
session, but I have no idea how to pinpoint the exact problem.

If anyone can offer me a suggest of how to track down what is keeping Mozilla
from going, please let me know, and I'll report further information...

Comment 1

18 years ago
Kevin, did you install mozilla-win32-installer.exe or one from of those ZIP files?
(Reporter)

Comment 2

18 years ago
I used the installer?  Should I acquire a copy of Mozilla with talkback?

Comment 3

18 years ago
No, the installer should be ok. It is only problematic if you use the ZIP
version exculsively as the installer writes some necessary stuff to the registry.

Do you get the splash screen? Does this problem occur after you used certain
applications?
(Reporter)

Comment 4

18 years ago
I don't see the splash screen.  I haven't been able to figure out if it occurs 
after starting a specific application.  I run so many different programs, that 
I have no way of keeping track of which I've run before starting Mozilla. I 
usually use IE, and every once in a while, go to test something in Mozilla, 
usually I end up having to reboot before I can.

It would be great if there's a way to examine what's running/been run so that I 
could see what the environment looks like when Mozilla works, compared to when 
it doesn't.

Comment 5

18 years ago
running sound apps, or directx apps, or hung dde apps?
(Reporter)

Comment 6

18 years ago
This is, I can't tell.  I'm acutally guessing it's DDE related.  I found that I 
was able to regain my access to Mozilla within a windows session by killing all 
everything attached to "Program Manager" (explorer.exe)... it's not explorer by 
itself that's blocking Mozilla cause it will run at the beginning of a windows 
session, but perhaps an extension or service running with explorer is causing 
the problem....

Comment 7

18 years ago
Anything using DirectX will also hang Mozilla see if any of the stuff loaded
into memory uses DirectX
I have had a problem loading Mozilla sometimes (along with Photoshop), and 
sometimes closing Outlook will cause it to load. Try opening Mozilla, and then 
going through and individually closing applications and take note of which one 
causes mozilla to load after its closed.

Comment 9

18 years ago
Reporter were you able to track down what program was hanging mozilla?
Keywords: hang
Summary: Problem with running Mozilla → Mozilla will not start
(Reporter)

Comment 10

18 years ago
I wasn't ever able to figure out exactly what is causing the problem.  I've had 
a theory that it has something to do with ICQ but haven't confirmed that.  It 
is equally likely that it isn't ICQ.  I also considered that it might be a DDE 
process of some kind tied to IE/Windows Explorer, but I have no idea how to 
test for that.

I have tried killing running apps and such with mozilla in memory, and loading 
mozilla after killing apps, but nothing has ever brought it back from the point 
where it stops loading, with the exception of restarting the computer and 
running it before it decides to stop working.

Comment 11

17 years ago
This symptom of "Hanging at runtime" is identical to the DDE Hangs that occur in
bug 53952 - this is even more likely given the fact that this does not occur
when the machine is first started.

Marking Dup of above bug.

*** This bug has been marked as a duplicate of 53952 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.