Last Comment Bug 692213 - IM: Assertion failure: Bad SSA value, at ../jsanalyze.h:1089
: IM: Assertion failure: Bad SSA value, at ../jsanalyze.h:1089
Status: RESOLVED FIXED
: assertion, testcase
Product: Core
Classification: Components
Component: JavaScript Engine (show other bugs)
: Other Branch
: x86_64 Linux
: -- major (vote)
: ---
Assigned To: David Anderson [:dvander]
:
Mentors:
Depends on:
Blocks: langfuzz
  Show dependency treegraph
 
Reported: 2011-10-05 12:18 PDT by Christian Holler (:decoder)
Modified: 2013-01-14 07:57 PST (History)
4 users (show)
choller: in‑testsuite+
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
fix (1.44 KB, patch)
2011-10-11 16:33 PDT, David Anderson [:dvander]
bhackett1024: review+
Details | Diff | Review

Description Christian Holler (:decoder) 2011-10-05 12:18:45 PDT
The following testcase asserts on ionmonkey revision acf3c1fb7c94 (run with --ion -n), tested on 64 bit:


function X(n) {
    while ('' + (n--)) {
        switch ( X( "w", "w*abc" ) ) { default : }   
    }
}
(X)();
Comment 1 David Anderson [:dvander] 2011-10-11 16:33:22 PDT
Created attachment 566393 [details] [diff] [review]
fix
Comment 2 Brian Hackett (:bhackett) 2011-10-11 18:51:21 PDT
Comment on attachment 566393 [details] [diff] [review]
fix

This is fine so long as the binaryOp inputs are best guesses and will be type checked later during compilation (which as I recall is the case).  Otherwise, due to coercion from a non-number value there could be a type mismatch between the input and output.
Comment 3 David Anderson [:dvander] 2011-10-11 19:29:48 PDT
https://hg.mozilla.org/projects/ionmonkey/rev/3486d7214539
Comment 4 Christian Holler (:decoder) 2013-01-14 07:57:38 PST
A testcase for this bug was automatically identified at js/src/jit-test/tests/ion/bug692213.js.

Note You need to log in before you can comment on or make changes to this bug.