All users were logged out of Bugzilla on October 13th, 2018

Re-directed to www.google.de

VERIFIED INVALID

Status

()

VERIFIED INVALID
18 years ago
16 years ago

People

(Reporter: bugzilla, Assigned: darin.moz)

Tracking

Trunk
x86
Windows NT
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

18 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; WinNT4.0; en-US; 0.8) Gecko/20010215
BuildID:    2001021508

Type "www.google.com" into the address box. Type Enter.
Ultimately the page www.google.de is loaded. I'm not German, but in the UK
expecting to go to the site www.google.com

If this is some DNS lookup problem it seem specific to Mozilla. Loading IE and
repeating takes me to the the expected English language site.

Reproducible: Always
Steps to Reproduce:
See description

Actual Results:  See description

Expected Results:  See description
I get something like

HTTP/1.0 302 Moved Temporarily
Location: http://www.google.de/

even when I send a plain (without "User-Agent:")

GET / HTTP/1.0
Host: www.google.com

So this looks not like a bug in Mozilla to me.
Maybe Google looks at your IP address and treats it wrong.
But I am German and the IP address I get by my ISP resolves to a *.de name.
Therefore it may be that Mozilla's UA string causes the error.

Reporter, have you tried this with cookies disabled? Google uses cookies.
Also, make sure you try with the same IP address in both Mozilla and IE (i.e.
use the same proxy configuration and don't cut the connection to your ISP
between both tries).

Comment 2

18 years ago
sounds like when we understand what's happening we'll resolve as invalid, 
although it is interesting and i'd like to know what's going on first...
Assignee: asa → darin
Component: Browser-General → Networking: HTTP
QA Contact: doronr → tever

Comment 3

18 years ago
Interesting, both .com and .de site's are located in the UK, on the same server.
Just try this to proof that:

ping www.google.com you get a reply from google.lb.google.com 64.209.200.100
ping www.google.de  you get a reply from google.lb.google.com 64.209.200.100

tracert www.google.com and tracert www.google.de ends at 64.209.200.100 
Also note that I don't get a HTTP/1.(0/1) 302 Moved Temporarily. And I did use a
protocol analyser for that. 

Reporter, can you attach your "tracert www.google.com > file.txt" to this bug??

Comment 4

18 years ago
And make sure that you do the same for www.google.de, thank you.
www.google.de  has CNAME www.google.com
www.google.com has CNAME google.lb.google.com

Asking ns.google.com I get 5 nameservers for lb.google.com. With all but the
last (helbdns.google.com) I get errors.

google.lb.google.com has A 64.208.34.100
                         A 64.208.32.100
                         A 64.209.200.100
                         A 216.239.37.100

Comment 6

18 years ago
for me www.google.de has CNAME google.lb.google.com but that doesn't matter
because it ends up at 64.209.200.100 anyway. I'm unable to reproduce the DNS
errors here, so that might be related to local network routing in Germany.

Comment 7

18 years ago
Andreas, when do you see those errors? Can you attach a trace route output? 
When you resolve those addresses, where does it stop, what is the last address?
No problem with tracert. But I cannot connect to them on port 53 using tcp.
Not tried with udp.

Tried another thing: Connected explicitly to the 4 IP addresses, but using
"Host: www.google.com" and without any "User-Agent:".
Got "200 OK" for 64.208.34.100, but a 302 redirecting to www.google.de for the
other 3. My IP address was 145.253.166.209, resolving to
muedi4-145-253-166-209.arcor-ip.net (known as German).

If I do the same from my website located in Nevada i get a 200 for all 4.

I'm pretty sure now that this is a problem at Google.
Suggesting to mark this bug invalid.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → INVALID
Got answer from Google:

--8<----
Hi -

As you have noticed Google has recently started using IP-address detection to 
help our users find our foreign
destination sites.  Unfortunately, our IP-address detection is not perfect and 
you are being inappropriately
redirected.  We are working on the problem.  In the interim, you can regain your 
old Google.com experience by
simply clicking on the "Google.com [English]" link in the footer of the page.  
By clicking on this, Google will
note that you have opted out of the foreign domain site and you will no longer 
experience redirects.

We apologize for any inconvenience.

The Google Team
--8<----

Resolving INVALID.

Comment 11

18 years ago
Hi, Google is attempting to redirect some users to a country-specific home page 
(German users get sent to google.de, for example) base on the IP address. We had 
some bad data on a few subnets though, esp. some Class C blocks that UUNet uses 
in the UK. These problems should be fixed now--sorry that you got this bug 
report.

Matt Cutts

Comment 12

16 years ago
Verified invalid.
Status: RESOLVED → VERIFIED
QA Contact: tever → junruh
You need to log in before you can comment on or make changes to this bug.