Closed Bug 692346 Opened 8 years ago Closed 8 years ago

explicitly require a /mnt/sdcard-based tegra devRoot

Categories

(Release Engineering :: General, defect)

x86
macOS
defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: aki, Assigned: aki)

Details

(Whiteboard: [android][tegra][sut_tools][android_tier_1])

Attachments

(1 file)

tegra-033 seems to not have an sdcard, so it's giving a bogus devRoot:


Connecting to: 10.250.49.20
reconnecting socket
send cmd: testroot

recv'ing...
response: /data/data/com.mozilla.SUTAgentAndroid/files


This is causing a ton of oranges.

Right now we're fine as long as devRoot is not None and not /tests.  We need to barf and set error.flg if not devRoot.startswith("/mnt/sdcard").


Taking tegra-033 out of production...
yes, this has been seen as the cause of half of the oranges I looked at on tbpl tonight.  Not saying that if this was fixed the test would be green:)
from logcat:
D/Vold    (  924): Volume sdcard state changing -1 (Initializing) -> 0 (No-Media)
The first instance of this will go purple, which isn't great.
However, now it will set the error flag and disable the tegra from running any more jobs, which reduces the oranges quite a bit.

Not sure if we want startswith("/mnt/sdcard") since that'll match other longer strings, but I don't see it being a glaring problem either.
Attachment #565110 - Flags: review?(jmaher)
Comment on attachment 565110 [details] [diff] [review]
devRoot must startwith("/mnt/sdcard")

Review of attachment 565110 [details] [diff] [review]:
-----------------------------------------------------------------

nice and simple!
Attachment #565110 - Flags: review?(jmaher) → review+
Comment on attachment 565110 [details] [diff] [review]
devRoot must startwith("/mnt/sdcard")

http://hg.mozilla.org/build/tools/rev/0bd747e8330a

I'll push these out to the foopies.
Attachment #565110 - Flags: checked-in+
Updated /builds/tools on foopy06 - 14.
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
Product: mozilla.org → Release Engineering
You need to log in before you can comment on or make changes to this bug.