IE Favorites truncated due to weird mutiple "." behavior

VERIFIED DUPLICATE of bug 53152

Status

SeaMonkey
Bookmarks & History
VERIFIED DUPLICATE of bug 53152
17 years ago
14 years ago

People

(Reporter: Mike Jaques, Assigned: Ben Goodger (use ben at mozilla dot org for email))

Tracking

({polish})

Trunk
x86
Windows 2000
polish

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
When a period is involved in an imported IE Favorite, the imported list is
truncated from that point on.  This was sort of resolved in an earlier bug, but
I have always noticed some strangeness even since.  I narrowed it down to a
testcase from a URL I had bookmarked in IE that was causing the problem.
(Reporter)

Comment 1

17 years ago
Ack, sorry about not finishing this all in one post, When an IE Favorite ends in
a "."   the file name it is assigned is  "filename..url"    which seems to be
giving the IE importer on mozilla a fit.  I cant even upload a testcase cause it
gives me an error using mozilla, I might try after using IE to see if I can
upload a minimal testcase that leads to the original URL that caused the
truncation on my Faves tree.

Using Mozilla win32 build 2001021708
(Reporter)

Updated

17 years ago
Keywords: correctness, polish

*** This bug has been marked as a duplicate of 53152 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE

Comment 3

17 years ago
vrfy dupe of bug 53152 filenames containing '..' or ending w/ '.' stop the 
directory enumerator (can affect imported favorites)
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.