Note: There are a few cases of duplicates in user autocompletion which are being worked on.

Advanced Search misses all search fields

RESOLVED FIXED in seamonkey2.7

Status

SeaMonkey
MailNews: Address Book & Contacts
--
major
RESOLVED FIXED
6 years ago
6 years ago

People

(Reporter: Hb, Assigned: InvisibleSmiley)

Tracking

Trunk
seamonkey2.7

SeaMonkey Tracking Flags

(seamonkey2.3 wontfix, seamonkey2.4 wontfix, seamonkey2.5 fixed, seamonkey2.6 fixed, seamonkey2.7 fixed)

Details

Attachments

(1 attachment)

2.20 KB, patch
Karsten Düsterloh
: review+
neil@parkwaycc.co.uk
: superreview+
neil@parkwaycc.co.uk
: approval-comm-aurora+
neil@parkwaycc.co.uk
: approval-comm-beta+
Details | Diff | Splinter Review
(Reporter)

Description

6 years ago
The Advanced Address Book Search dialog has two dropdowns in the criteria list.  The first one should have the target column names and the second one the condition operators. Both dropdowns are empty. 

Advanced Search is therefore completely broken.

Confirmed on Version 2.4 and on Trunk, perhaps a bug since 2.x.

Comment 1

6 years ago
Error: Component returned failure code: 0x80004002 (NS_NOINTERFACE) [nsISupports.QueryInterface]
Source file: chrome://messenger/content/ABSearchDialog.js
Line: 155

Probably fallout from deRDF addressbook bug.

function GetScopeForDirectoryURI(aURI)
{
  var directory = gRDF.GetResource(aURI).QueryInterface(nsIAbDirectory);
Should be:
  var directory = MailServices.ab.getDirectory(aURI);

See Bug 652855 and http://hg.mozilla.org/comm-central/rev/e3f147cb26aa#l1.1
Depends on: 652855
OS: Windows 7 → All
Hardware: x86_64 → All
(Assignee)

Comment 2

6 years ago
Bah, seems I missed this in bug 654864 because I only referred to abCommon.js in my bug 652855 comment. :-(
Assignee: nobody → jh
Status: NEW → ASSIGNED
(Assignee)

Updated

6 years ago
status-seamonkey2.3: --- → wontfix
status-seamonkey2.4: --- → wontfix
status-seamonkey2.5: --- → affected
status-seamonkey2.6: --- → affected
status-seamonkey2.7: --- → affected
(Assignee)

Comment 3

6 years ago
Created attachment 565305 [details] [diff] [review]
patch [Checkin: comment 5]

Going for MOA
Attachment #565305 - Flags: superreview?(mnyromyr)
Attachment #565305 - Flags: review?(mnyromyr)
Attachment #565305 - Flags: approval-comm-beta?
Attachment #565305 - Flags: approval-comm-aurora?
(Reporter)

Comment 4

6 years ago
I tested the patch with a homebrew non optimized omni.jar. Target columns and conditions appear now. Search works fine when started with the Search button or typing Alt+S.

But when the search is started by Enter key after typing in the condition text the dialog window closes completely without result. This behaviour may be another bug.

Updated

6 years ago
Attachment #565305 - Flags: superreview?(mnyromyr)
Attachment #565305 - Flags: superreview+
Attachment #565305 - Flags: approval-comm-beta?
Attachment #565305 - Flags: approval-comm-beta+
Attachment #565305 - Flags: approval-comm-aurora?
Attachment #565305 - Flags: approval-comm-aurora+
(Assignee)

Updated

6 years ago
tracking-seamonkey2.5: --- → ?

Updated

6 years ago
Attachment #565305 - Flags: review?(mnyromyr) → review+
(Assignee)

Comment 5

6 years ago
Comment on attachment 565305 [details] [diff] [review]
patch [Checkin: comment 5]

http://hg.mozilla.org/comm-central/rev/1878d5d66a78
http://hg.mozilla.org/releases/comm-aurora/rev/e9cb3f0268cf
http://hg.mozilla.org/releases/comm-beta/rev/75c1190bc182
Attachment #565305 - Attachment description: patch → patch [Checkin: comment 5]
(Assignee)

Updated

6 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 6 years ago
status-seamonkey2.5: affected → fixed
status-seamonkey2.6: affected → fixed
status-seamonkey2.7: affected → fixed
tracking-seamonkey2.5: ? → ---
Resolution: --- → FIXED
Target Milestone: --- → seamonkey2.7
You need to log in before you can comment on or make changes to this bug.