Closed Bug 692435 Opened 9 years ago Closed 9 years ago

Win opt test failures on inbound: "Timed out while waiting for server startup"

Categories

(Release Engineering :: General, defect)

x86
Windows 7
defect
Not set
critical

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: emorley, Assigned: bhearsum)

References

Details

Filing this so that there is something to link to from the TBPL closed tree message + so if this turns out to be infra, the cause can be investigated.

Win opt test on inbound current tip (https://tbpl.mozilla.org/?tree=Mozilla-Inbound&rev=62d490b0433f) are orange, with:
"Timed out while waiting for server startup"
eg: https://tbpl.mozilla.org/php/getParsedLog.php?id=6702063&tree=Mozilla-Inbound

That changeset only backed out a GTK related change (that had only landed a few pushes before), so cannot be related. 

However, what is strange is that retriggers of 62d490b0433f tests come back orange, whereas retriggers of the last known green win opt tests (https://tbpl.mozilla.org/?tree=Mozilla-Inbound&rev=f8fa25d9551c) come back green.

The only conclusion reached on #build so far is that it was an infra issue that broke the 62d490b0433f win opt build, such that the tests always fail.

Retriggers of the win opt build have been requested for 62d490b0433f (and the last known win opt green, f8fa25d9551c, just to be sure).

<Got interrupted by a call, so the above is now slightly out of date; but am going to file this anyway, so at least we have something to point at>

Is now looking like this might be due to needing a clobber post PGO change.
(In reply to Ed Morley [:edmorley] from comment #0)
> Is now looking like this might be due to needing a clobber post PGO change.

Joel figured out that xpcshell.exe was looking for pgort80.dll, which is wrong for non-PGO builds, which strongly hints towards this theory. I marked all of the win opt builds on all branches for clobbers, and requested a new build on m-i. This will almost certainly fix the issue, but I'll leave this bug open until we can confirm that.
Assignee: nobody → bhearsum
Blocks: 658313
https://tbpl.mozilla.org/?tree=Mozilla-Inbound&rev=62d490b0433f has gone green after the clobber + retrigger, so the conclusion in comment 1 is correct.

Thanks Joel & Ben! :-)
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → FIXED
Product: mozilla.org → Release Engineering
You need to log in before you can comment on or make changes to this bug.