Regression: Old style dialog is shown when file upload input filed has multiple attribute

RESOLVED DUPLICATE of bug 689732

Status

()

RESOLVED DUPLICATE of bug 689732
7 years ago
7 years ago

People

(Reporter: rservus, Unassigned)

Tracking

({regression})

7 Branch
x86
Windows 7
regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

7 years ago
Created attachment 565249 [details]
different file upload dialogs in multipe and single file mode

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:7.0.1) Gecko/20100101 Firefox/7.0.1
Build ID: 20110928134238

Steps to reproduce:

When html form file input field has attribute multiple click on "Browse"  button opens system dialog to choose files.

system: Windows 7, 64 bit
browser: Firefox 7.0.1 (standard distribution)


Actual results:

Old style (Win XP style) file dialog is shown instead of Win7 default file select dialog. When file input field doesn't have multiple attribute than correct dialog is shown.
It is regression. 6.x versions shows correct dialog in multiple and single mode.


Expected results:

Default Win7 new style file select dialog should be shown whether multiple attribute is present or not.
Duplicate of this bug: 692480

Comment 2

7 years ago
I can reproduce on Firefox7.0.1 and Firefox8.0beta;
http://hg.mozilla.org/releases/mozilla-release/rev/58f3edbff1b9
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:7.0.1) Gecko/20100101 Firefox/7.0.1 ID:20110928134238
http://hg.mozilla.org/releases/mozilla-beta/rev/8c16a7575d10
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:8.0) Gecko/20100101 Firefox/8.0 ID:20110928060149

I cannot reproduce on Aurora9.0a2 and Nightly10.0a1

This is similar to Bug 684506. However regression range is different.

Regression window(m-c hourly)
Works;
http://hg.mozilla.org/mozilla-central/rev/7aa58a99a2e5
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:7.0a1) Gecko/20110630 Firefox/7.0a1 ID:20110630003937
Fails:
http://hg.mozilla.org/mozilla-central/rev/5c246f2bccb1
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:7.0a1) Gecko/20110630 Firefox/7.0a1 ID:20110630035829


Regression window(mi hourly)
Works;
http://hg.mozilla.org/integration/mozilla-inbound/rev/720ec564772b
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:7.0a1) Gecko/20110629 Firefox/7.0a1 ID:20110629125327
Fails:
http://hg.mozilla.org/integration/mozilla-inbound/rev/d74a91fd10a8
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:7.0a1) Gecko/20110629 Firefox/7.0a1 ID:20110629140328
Pushlog:
http://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=720ec564772b&tochange=d74a91fd10a8

Suspected bug:
84533f5e86bf	Brian Bondy — Bug 660833 - Fix for forms with input multiple on Windows do not accept more than 253 files at once. r=jimm
Blocks: 660833
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: regression
Hardware: x86_64 → x86
This is already fixed in Aurora, but let me know if you think we should suggest it gets fixed in Beta.
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 689732
You need to log in before you can comment on or make changes to this bug.