Last Comment Bug 692674 - IndexedDB: Set the errorCode to "ABORT_ERR" for *all* pending requests when IDBTransaction.abort() is called
: IndexedDB: Set the errorCode to "ABORT_ERR" for *all* pending requests when I...
Status: RESOLVED FIXED
: dev-doc-complete
Product: Core
Classification: Components
Component: DOM: IndexedDB (show other bugs)
: unspecified
: x86 Mac OS X
: -- normal (vote)
: ---
Assigned To: Jonas Sicking (:sicking) PTO Until July 5th
:
Mentors:
Depends on:
Blocks: idb
  Show dependency treegraph
 
Reported: 2011-10-06 17:51 PDT by Jonas Sicking (:sicking) PTO Until July 5th
Modified: 2012-03-22 11:54 PDT (History)
6 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Patch to fix (5.34 KB, patch)
2011-11-07 20:28 PST, Jonas Sicking (:sicking) PTO Until July 5th
bent.mozilla: review+
Details | Diff | Review

Description Jonas Sicking (:sicking) PTO Until July 5th 2011-10-06 17:51:03 PDT
Currently we only do this on requests which are successful.
Comment 1 Jonas Sicking (:sicking) PTO Until July 5th 2011-11-07 20:28:16 PST
Created attachment 572737 [details] [diff] [review]
Patch to fix
Comment 2 Ben Turner (not reading bugmail, use the needinfo flag!) 2011-11-07 20:42:39 PST
Comment on attachment 572737 [details] [diff] [review]
Patch to fix

Review of attachment 572737 [details] [diff] [review]:
-----------------------------------------------------------------

::: dom/indexedDB/AsyncConnectionHelper.cpp
@@ +228,2 @@
>        // Don't fire success events if the transaction has since been aborted.
>        // Instead convert to an error event.

Nit: Fix this comment to say something about always firing ABORT_ERR for success and other errors?
Comment 3 Jonas Sicking (:sicking) PTO Until July 5th 2011-11-07 22:32:14 PST
Checked in https://hg.mozilla.org/mozilla-central/rev/c131defb532c

Thanks for quick review!

Note You need to log in before you can comment on or make changes to this bug.