Closed Bug 692713 Opened 8 years ago Closed 4 years ago

Crash EXCEPTION_ACCESS_VIOLATION_READ at gfxContext::gfxContext(gfxASurface*)

Categories

(Core :: Graphics, defect, critical)

7 Branch
All
Windows 7
defect
Not set
critical

Tracking

()

RESOLVED DUPLICATE of bug 1276062

People

(Reporter: attekett, Unassigned)

References

Details

(Keywords: crash, regression, testcase)

Crash Data

Attachments

(2 files)

Not reproducable on Ubuntu 11.04 x86_64. 

Open attached file in Firefox 7.0.1, Firefox 8.0b1 or Aurora 9.0a2 to reproduce.

Works fine on Windows 7 x64 - Firefox 6.0.2 

In older version page shows spinning rectangle with an html-button, but instead spins only quarter of a lap and then crashes.

Related Crash Report:
https://crash-stats.mozilla.com/report/index/bp-79976a66-bafd-43a9-821f-6f8f12111006
Attached file crash-repro-file
Confirmed on
http://hg.mozilla.org/mozilla-central/rev/8c82de08425d
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:10.0a1) Gecko/20111006 Firefox/10.0a1 ID:20111006030949

Browser crashes if HWA on.
bp-6dae9fa4-29d9-4659-8bce-5b9c92111007


Regression window(m-c hourly),
Works:
http://hg.mozilla.org/mozilla-central/rev/a23353de5415
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:7.0a1) Gecko/20110622 Firefox/7.0a1 ID:20110622112035
Fails:
http://hg.mozilla.org/mozilla-central/rev/cd95d565c4d9
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:7.0a1) Gecko/20110622 Firefox/7.0a1 ID:20110622125401
Pushlog:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=a23353de5415&tochange=cd95d565c4d9


Regression window(m-i hourly),
Works:
http://hg.mozilla.org/integration/mozilla-inbound/rev/ff8bd5d40a57
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:7.0a1) Gecko/20110622 Firefox/7.0a1 ID:20110622034824
Fails:
http://hg.mozilla.org/integration/mozilla-inbound/rev/e302cef502f6
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:7.0a1) Gecko/20110622 Firefox/7.0a1 ID:20110622051524
Pushlog:
http://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=ff8bd5d40a57&tochange=e302cef502f6

Suspected bug:
Bug 637852 - Move resolution handling out of layer system into FrameLayerBuilder
Blocks: 637852
Severity: normal → critical
Status: UNCONFIRMED → NEW
Crash Signature: [@ gfxContext::gfxContext(gfxASurface*)] [@ cairo_d2d_surface_create_for_texture]
Component: General → Graphics
Ever confirmed: true
OS: Windows 7 → All
Product: Firefox → Core
QA Contact: general → thebes
Hardware: x86_64 → All
Attachment #565446 - Attachment mime type: text/plain → text/html
OS: All → Windows 7
It's #28 top crasher in 10.0.
Keywords: topcrash
Version: 8 Branch → 7 Branch
There are 22 crashes in 13.0.
Keywords: topcrash
Crash Signature: [@ gfxContext::gfxContext(gfxASurface*)] [@ cairo_d2d_surface_create_for_texture] → [@ gfxContext::gfxContext(gfxASurface*)] [@ cairo_d2d_surface_create_for_texture] [@ gfxContext::gfxContext]
Attached file memory-report.json.gz
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1276062
You need to log in before you can comment on or make changes to this bug.