Last Comment Bug 692767 - about:home shows tabs from last time with wrong encoding, non-ASCII characters are broken
: about:home shows tabs from last time with wrong encoding, non-ASCII character...
Status: VERIFIED FIXED
: regression, verified-aurora
Product: Fennec Graveyard
Classification: Graveyard
Component: General (show other bugs)
: Trunk
: ARM Android
: -- normal (vote)
: Firefox 9
Assigned To: Mark Finkle (:mfinkle) (use needinfo?)
:
Mentors:
: 692797 (view as bug list)
Depends on:
Blocks: 691534
  Show dependency treegraph
 
Reported: 2011-10-07 06:33 PDT by Sebastian H. [:aryx][:archaeopteryx]
Modified: 2011-10-19 18:02 PDT (History)
5 users (show)
See Also:
QA Whiteboard:
Iteration: ---
Points: ---


Attachments
screenshot of about:home with broken character (46.84 KB, image/png)
2011-10-07 06:33 PDT, Sebastian H. [:aryx][:archaeopteryx]
no flags Details
patch (1.39 KB, patch)
2011-10-07 09:33 PDT, Mark Finkle (:mfinkle) (use needinfo?)
mbrubeck: review+
asa: approval‑mozilla‑aurora+
Details | Diff | Review

Description Sebastian H. [:aryx][:archaeopteryx] 2011-10-07 06:33:07 PDT
Created attachment 565513 [details]
screenshot of about:home with broken character

about:home shows the tabs from last time with a wrong encoding (latin 1?), the special characters are broken.

Steps to reproduce:
1. Open a new tab.
2. Type "österreich" into it and start a google search.
3. Call Menu > More > Quit.
4. Launch Firefox Mobile.

Actual result:
The "ö" is replaced by other characters.

Expected result:
Tab title contains "österreich".

This is a regression only on nightly, starting with 2011-10-05's nightly.
Comment 1 Mark Finkle (:mfinkle) (use needinfo?) 2011-10-07 08:59:11 PDT
*** Bug 692797 has been marked as a duplicate of this bug. ***
Comment 2 Martijn Wargers [:mwargers] (gone per 2016-05-31 :-( ) 2011-10-07 09:01:01 PDT
From bug 692797, comment 1:
This is a regression from bug 691534, which switched to use NetUtils.readInputStreamToString
Comment 3 Richard Newman [:rnewman] 2011-10-07 09:03:43 PDT
Fixing nonchalant Americanism in title.
Comment 4 Martijn Wargers [:mwargers] (gone per 2016-05-31 :-( ) 2011-10-07 09:25:50 PDT
From duped bug 692797, comment 2:
I thought we were working like the code in Sync:
Saving with UTF-8
http://mxr.mozilla.org/mozilla-central/source/services/sync/modules/util.js#841

Reading without doing anything:
http://mxr.mozilla.org/mozilla-central/source/services/sync/modules/util.js#805
Comment 5 Mark Finkle (:mfinkle) (use needinfo?) 2011-10-07 09:33:19 PDT
Created attachment 565558 [details] [diff] [review]
patch

This is a regression caused by bug 691534, which switched to use NetUtils.readInputStreamToString and stop converting the UTF-8

This patch reverts part of bug 691534 so we convert the UTF-8
Comment 6 Matt Brubeck (:mbrubeck) 2011-10-07 11:20:45 PDT
Comment on attachment 565558 [details] [diff] [review]
patch

Sorry for missing this in review of bug 691534.
Comment 7 Mark Finkle (:mfinkle) (use needinfo?) 2011-10-07 12:37:43 PDT
https://hg.mozilla.org/integration/mozilla-inbound/rev/3eeb0e021d80
Comment 8 Mark Finkle (:mfinkle) (use needinfo?) 2011-10-07 12:40:27 PDT
Comment on attachment 565558 [details] [diff] [review]
patch

This patch backs out part of bug 691534, but doesn't affect the performance improvements. It just fixes the UTF-8 character handling.

I think we want this to go along in Aurora with the performance improvements in bug 691534.
Comment 9 Kyle Huey [:khuey] (khuey@mozilla.com) (Away until 6/13) 2011-10-09 07:31:39 PDT
https://hg.mozilla.org/mozilla-central/rev/3eeb0e021d80
Comment 10 Aaron Train [:aaronmt] 2011-10-11 06:39:41 PDT
Mozilla/5.0 (Android; Linux armv7l; rv:10.0a1) Gecko/20111011 Firefox/10.0a1 Fennec/10.0a1
Samsung Galaxy SII (2.3.4)
Comment 11 Mark Finkle (:mfinkle) (use needinfo?) 2011-10-13 06:34:29 PDT
https://hg.mozilla.org/releases/mozilla-aurora/rev/b707c898e867
Comment 12 Aaron Train [:aaronmt] 2011-10-19 18:02:10 PDT
Mozilla/5.0 (Android; Linux armv7l; rv:9.0a2) Gecko/20111019 Firefox/9.0a2 Fennec/9.0a2

Note You need to log in before you can comment on or make changes to this bug.