The default bug view has changed. See this FAQ.

Reftests for bug 437722 fail on Android

RESOLVED FIXED in mozilla10

Status

()

Core
Widget: Android
RESOLVED FIXED
6 years ago
6 years ago

People

(Reporter: Ehsan, Assigned: Ehsan)

Tracking

Trunk
mozilla10
x86
Mac OS X
Points:
---
Bug Flags:
in-testsuite +

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 1 obsolete attachment)

(Assignee)

Description

6 years ago
https://tbpl.mozilla.org/php/getParsedLog.php?id=6726997&tree=Mozilla-Inbound&full=1

I'll disable them on Android for now.
Could be a regression.
Did the tests pass on tryserver?
(Assignee)

Comment 3

6 years ago
(In reply to Martijn Wargers [:mw22] (QA - IRC nick: mw22) from comment #1)
> Could be a regression.

No, because I just checked them in.  :-)

(In reply to Chris Jones [:cjones] [:warhammer] from comment #2)
> Did the tests pass on tryserver?

Now that I checked more closely, they didn't.  And they're perma failures.  But I would like to keep the tests in the tree, since the thing which they're actually testing is working correctly as far as I can tell.
I (In reply to Ehsan Akhgari [:ehsan] from comment #3)
> (In reply to Martijn Wargers [:mw22] (QA - IRC nick: mw22) from comment #1)
> > Could be a regression.
> 
> No, because I just checked them in.  :-)

I mean that this reftest could at one point have worked in Fennec, but failed in more recent builds.
Well, let me note "uncool, man" and slap you on the wrist ;).

I can't tell why the first test failed because the "before 376832, after 376832, break 05800000" spam (may it rot in hell) corrupted the png data: URI.  The second test is just failing because the test image has rounded corners and the reference doesn't.  Is there some default style fennec is using that the test isn't turning off properly?

If so, this is likely reproducible with a fennec-desktop build.
Yeah, buttons are rounded on Fennec.
http://mxr.mozilla.org/mozilla-central/source/mobile/themes/core/content.css#151
I guess that reftest needs fixing.
(Assignee)

Comment 7

6 years ago
Created attachment 567384 [details] [diff] [review]
Patch (v1)

I totally deserved cjones slapping my wrists.  :(

But I need to restore my reputation here, so here's a patch to force the button's border to not be round.
Assignee: nobody → ehsan
Status: NEW → ASSIGNED
Attachment #567384 - Flags: review?(mbrubeck)
(Assignee)

Comment 8

6 years ago
Created attachment 567385 [details] [diff] [review]
Patch (v1)

Removed the unneeded comment in the reftest.list file.
Attachment #567384 - Attachment is obsolete: true
Attachment #567384 - Flags: review?(mbrubeck)
Attachment #567385 - Flags: review?(mbrubeck)
(Assignee)

Comment 9

6 years ago
https://tbpl.mozilla.org/?tree=Try&rev=cc3facb1432d

Comment 10

6 years ago
Try run for cc3facb1432d is complete.
Detailed breakdown of the results available here:
    https://tbpl.mozilla.org/?tree=Try&rev=cc3facb1432d
Results (out of 2 total builds):
    success: 2
Builds available at http://ftp.mozilla.org/pub/mozilla.org/firefox/try-builds/eakhgari@mozilla.com-cc3facb1432d
Comment on attachment 567385 [details] [diff] [review]
Patch (v1)

Note that you'll need to use "-u reftest-1" to get Android results on Try, because of bug 664857.
Attachment #567385 - Flags: review?(mbrubeck) → review+

Comment 12

6 years ago
Try run for df2310393f24 is complete.
Detailed breakdown of the results available here:
    https://tbpl.mozilla.org/?tree=Try&rev=df2310393f24
Results (out of 16 total builds):
    exception: 10
    success: 6
Builds available at http://ftp.mozilla.org/pub/mozilla.org/firefox/try-builds/eakhgari@mozilla.com-df2310393f24
(Assignee)

Comment 13

6 years ago
https://hg.mozilla.org/integration/mozilla-inbound/rev/2b1f937914ff
Flags: in-testsuite+
Target Milestone: --- → mozilla10
https://hg.mozilla.org/mozilla-central/rev/2b1f937914ff
Status: ASSIGNED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.