Thunderbird plays Windows error sound whenever a dialog window, menu bar item, or dropdown is opened for the first time.

RESOLVED WORKSFORME

Status

()

Core
Widget: Win32
RESOLVED WORKSFORME
6 years ago
6 years ago

People

(Reporter: benshadwick, Unassigned)

Tracking

7 Branch
x86_64
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:7.0.1) Gecko/20100101 Firefox/7.0.1
Build ID: 20110928134238

Steps to reproduce:

Opened Thunderbird 7.0.1 in Windows 7 x64 Pro and then opened various dialog windows (e.g. About), menu bar items, and dropdown lists.


Actual results:

The Windows error sound played the first time any of the aforementioned UI element instances were activated.

I made a youtube video using FRAPS so that you can see/hear it first-hand: http://www.youtube.com/watch?v=eiP6uNfsa2s

I actually first noticed this in Thunderbird 5.x, and it is one of the main reasons I updated.

Note that this is not related to the new mail sound or related settings. I tried messing with those and they had no bearing on this issue.


Expected results:

The Windows error sound should not be played as a result of activation/appearance of random UI elements.
(Reporter)

Comment 1

6 years ago
I should also mention that this does not occur in other Windows apps (including Firefox 7.0.1), so it is not an OS-level issue.

Comment 2

6 years ago
Is this a clean install of Thunderbird? There are no account configured, so you are probably using a new profile. Are there any extensions?
(Reporter)

Comment 3

6 years ago
(In reply to aceman from comment #2)
> Is this a clean install of Thunderbird? There are no account configured, so
> you are probably using a new profile. Are there any extensions?
There is no account configured in the video because I uninstalled Thunderbird, manually purged all traces of it from my system (including settings files and registry entries), then reinstalled to try to get a clean install in case it was some hidden configuration option causing it.

I have no extensions installed, nor did I have any before the reinstall.

Comment 4

6 years ago
I am CCing Ehsan, because he seems to know about Windows sounds (due to bug 604451).
Component: General → Widget: Win32
Product: Thunderbird → Core
QA Contact: general → win32
Version: 7 → 7 Branch

Comment 5

6 years ago
(In reply to aceman from comment #4)
> I am CCing Ehsan, because he seems to know about Windows sounds (due to bug
> 604451).

I don't know anything about what Thunderbird is doing though.  Somebody should just set a breakpoint on nsISound stuff and see what's causing this.
(Reporter)

Comment 6

6 years ago
This is still happening in Thunderbird 8.0 under Windows 7 Pro x64 using the Standard Installation options and location. I once again removed all Thunderbird-related files and registry entries from my system before installing.
(Reporter)

Comment 7

6 years ago
This seems to have been mysteriously fixed in 9.0.1.

Comment 8

6 years ago
Thanks. Reopen the bug if it happens again.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.