Ayanata scrollbars not supported

RESOLVED WONTFIX

Status

()

Core
Widget: Gtk
RESOLVED WONTFIX
7 years ago
2 years ago

People

(Reporter: Emanuele, Unassigned)

Tracking

Trunk
All
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 years ago
User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:7.0.1) Gecko/20100101 Firefox/7.0.1
Build ID: 20110929022028

Steps to reproduce:

Firefox does not support Ayatana scrollbars in Ubuntu 10.10. Scrollbars are rendered as plain GTK. 

Launchpad bug: https://bugs.launchpad.net/ayatana-scrollbar/+bug/847922

Comment 1

7 years ago
Actually this is not a Bug of Firefox but of the Ayanata Scrollbar so it should be fixed there and not here.

Comment 2

7 years ago
(In reply to bjoern.online from comment #1)
> Actually this is not a Bug of Firefox but of the Ayanata Scrollbar so it
> should be fixed there and not here.

Can you tell us more about this?

Updated

6 years ago

Updated

6 years ago

Comment 3

6 years ago
It looks like something that should be fixed in Firefox (and Thunderbird), just as the similar bug 636564 on OS X is being fixed in Firefox.

Comment 4

5 years ago
Reporter: please change the Product field to "Core", the Component field to "Widget: Gtk", the Hardware field to "All", and the Branch field to "Trunk". Thanks!

Comment 5

5 years ago
Changes Alex Jordan requested have been made, except for "Widget: Gtk" as it is not an option on the component dropdown.
Component: Toolbars and Customization → Widget: Gtk
Product: Firefox → Core
Hardware: x86_64 → All
Version: 7 Branch → Trunk

Comment 6

4 years ago
Almost a year since the last post, using firefox 30; no overlay-scrollbars :(

Was there any more progress on this issue?

Comment 7

3 years ago
(In reply to Que Quotion from comment #6)
> Almost a year since the last post, using firefox 30; no overlay-scrollbars :(
> 
> Was there any more progress on this issue?

 If this bug wasn't updated, then there almost certainly wasn't any progress.

Comment 8

2 years ago
Ubuntu has dropped support for these scrollbars
Thanks for the info.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → WONTFIX

Comment 10

2 years ago
>>7
Not necessarily so. Experience has taught me that FOSS is riddled with duplication of effort; that a problem may be solved directly or indirectly without anyone being informed; and that bug reports are, most of the time, a last resort for lost hopes.

>>8
Clarification: Ubuntu has dropped support for these scrollbars because they expect the GNOME overlay-scrollbars to be implemented.

Is that going to happen?

Comment 11

2 years ago
I believe they did drop the Ayanata scrollbar for the Gnome scrollbar in Ubuntu 16.04 LTS Xenial Xerus.  I read that somewhere, but now I fail to find any article on the subject on the web.  I am using now using Ubuntu 16.04 LTS Xenial Xerus and the scrollbars are different than the old ones.

As the moment of this writing, I cannot test Firefox and check its behavior under Ubuntu 16.04 LTS Xenial Xerus.
You need to log in before you can comment on or make changes to this bug.