"arbitrary" selection of download directory in multiple tabs (tabs with different server name)

RESOLVED DUPLICATE of bug 702748

Status

()

Toolkit
Downloads API
RESOLVED DUPLICATE of bug 702748
6 years ago
6 years ago

People

(Reporter: HC, Unassigned)

Tracking

7 Branch
x86_64
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:7.0.1) Gecko/20100101 Firefox/7.0.1
Build ID: 20110928134238

Steps to reproduce:

I have configured Firfox (since long) to ask for the download directory.
Consider a Flickr album with a number of photos, which I opened in one new tab each. Next I step through each tab (with one photo displayed) and want to save the image.


Actual results:

Firefox presents me a kind of "arbitrary" directory where to save the photo in each tab. This starts with the (default) downloads directory, sometimes it is the directory used last, sometimes it is a directory, which was used sometimes earlier.


Expected results:

Like in the previews Firefox issues the most recently used directory shall be proposed. Saving images into different and unrelated directories in sequentially visited tabs is a new malbehaviour in FF 7.0.1.
(Reporter)

Comment 1

6 years ago
The issue cannot simply be reproduced. It works for sometimes as expected, then without any changed user behaviour or settings changes the download directories become arbitrary, then later it works fine again.
P.S. Usually I put my computer into stand-by and do not restart FF the next day. That is, FF usually runs for some weeks. Current memory usage is about 400MB, I sometimes have around 30-40 tabs open in one window. A second window with a few tabs was open when the issue occurred.
P.P.S. FF sometimes crashes with the first website after being woken up again. (but this would be another issue)

Comment 2

6 years ago
Does it happen when downloading from the same site? In your original description it is the case (Flickr).

Since some version Firefox started to remember download folder per site. But it probably is since 8.
(Reporter)

Comment 3

6 years ago
It happens independent of a website. All photo urls for Flickr, for instance, use the same base address, and the download directory changes from tab to tab.
(Reporter)

Comment 4

6 years ago
I have analysed the misbehaviour more thoroughly according to Comment #2.

The comment actually describes this misbehaviour: Photos on a flickr page appear to come from "www.flickr.com". But some of them may be stored on "farm7.static.flickr.com" or "farm2.static.flickr.com" or wherever. In other words, FF seems to assume that all these sites are "different" and selects the standard download directory within the photos of one album. 

This is also the case for image hosts, like img$$$.imagevenue.com, where $$$ represents arbitrary figures.

I usually store downloaded photos in one directory per album and since FF 7 I always have to take care of the guessed directory and need to travel over disks and many directories to store the photos in the directory that I want to use.

But the situation is even worse: The "farms" flickr uses are not related to a user. Sometimes later in the session, the same farm may be used for a different album photo and FF remembers that there is a directory associated with that address and suggests to use it. This only supports mess on my computer...

In summary, this misbehaviour may acutally be a "feature", but without a switch to turn it off, it would be a reason for me to try another browser that lets me save photos quickly without navigating my disks and directories at the places I want.

Updated

6 years ago
Blocks: 536503

Comment 5

6 years ago
The change was implemented in bug 536503 and is there since Firefox 7. I have asked there if it can be turned off.
Component: General → Download Manager
Product: Firefox → Toolkit
QA Contact: general → download.manager
Summary: "arbitrary" selection of download directory in multiple tags → "arbitrary" selection of download directory in multiple tabs (tabs with different server name)

Comment 6

6 years ago
I was just trying to find out why my downloads kept jumping around and found this bug.  It is quite annoying.

Comment 7

6 years ago
This highly annoying bug was introduced by "feeture" https://bugzilla.mozilla.org/show_bug.cgi?id=536503.  Please turn it off!
fyi. Preference to turn off this feature is added in https://bugzilla.mozilla.org/show_bug.cgi?id=702748

Updated

6 years ago
No longer blocks: 536503
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Depends on: 536503
Resolution: --- → DUPLICATE
Duplicate of bug: 702748
You need to log in before you can comment on or make changes to this bug.