New autocomplete handling conflicts with Wikipedia's autocomplete

RESOLVED INVALID

Status

()

Core
DOM: Core & HTML
RESOLVED INVALID
6 years ago
6 years ago

People

(Reporter: Alessandro, Unassigned)

Tracking

({regression})

Trunk
regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 1 obsolete attachment)

688 bytes, text/html
Details
(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:9.0a2) Gecko/20111008 Firefox/9.0a2
Build ID: 20111008042014

Steps to reproduce:

1.) Opened http://en.wikipedia.org/wiki/Main_Page?useskin=monobook
2.) Typed a search term in the Search bar on the left


Actual results:

Nothing until I used backspace to delete a character from the search term


Expected results:

Wikipedia's suggestions should be shown

Comment 1

6 years ago
Confirmed on
http://hg.mozilla.org/mozilla-central/rev/b4da2d439cbc
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:10.0a1) Gecko/20111009 Firefox/10.0a1 ID:20111009031012


[STR]:
1. Open Firefox with clean profile
2. Open URL( http://en.wikipedia.org/wiki/Main_Page?useskin=monobook )
3. Key in "f" without quotation marks. to search field at left sidebar.


[Actual]:
Nothing happen.
(if key in "i" followed by "f", suggestion pops up. And delete all text, and key in "f" again, the suggestion pops up.)

[Expected]
The suggestion should pop up.



Regression window(cached m-c hourly):
Works:
http://hg.mozilla.org/mozilla-central/rev/008a0b8578db
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b6pre) Gecko/20100909 Firefox/4.0b6pre ID:20100909231905
Fails:
http://hg.mozilla.org/mozilla-central/rev/6ccd956d1df9
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b6pre) Gecko/20100909 Firefox/4.0b6pre ID:20100909235647
Pushlog:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=008a0b8578db&tochange=6ccd956d1df9

Suspected bug:
Bug 556007 - Implement list attribute
Blocks: 556007
Status: UNCONFIRMED → NEW
Component: General → DOM: Core & HTML
Ever confirmed: true
Keywords: regression
Product: Firefox → Core
QA Contact: general → general
Hardware: x86_64 → x86

Comment 2

6 years ago
Created attachment 565816 [details]
small width

And the size of the popup is small.
The popup should expand the width to fit its content.

Updated

6 years ago
Attachment #565816 - Attachment is obsolete: true

Comment 3

6 years ago
Please ignore comment #2
The suggestion popups just seems to be slow. I would bet they are doing some XHR when we type. If you type 'p', waits a bit and type 'i', you will see something popping.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
OS: Windows 7 → All
Hardware: x86 → All
Resolution: --- → WORKSFORME
Version: 9 Branch → Trunk
No longer blocks: 556007

Comment 5

6 years ago
(In reply to Mounir Lamouri (:volkmar) (:mounir) from comment #4)
If you type 'p', waits a bit and type 'i', you will see
> something popping.


If you type 'p' nothing happen at the first time, this is regression.
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---

Comment 6

6 years ago
Created attachment 566112 [details]
sample ( bat practice )

The web page creates <datalist> and 'list' attribute when a text is input for the first time, .

if datalist and list attribute are dynamically added after 100ms when a text is input, the popup will not pop up. see sample.

So I guess this is site issue.

Updated

6 years ago
Status: REOPENED → RESOLVED
Last Resolved: 6 years ago6 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.