Content scripts should have separate scopes

RESOLVED DUPLICATE of bug 673569

Status

()

Core
General
RESOLVED DUPLICATE of bug 673569
7 years ago
4 years ago

People

(Reporter: Jesse Ruderman, Unassigned)

Tracking

Trunk
x86
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 years ago
If I have "const Cc = Components.classes;" in one of my extension's content scripts, chrome://browser/content/content.js hits "redeclaration of const Cc".

It's like the bad old days of XUL overlays :(

Updated

7 years ago
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 673569
You need to log in before you can comment on or make changes to this bug.