Make Firefox homepage similar to Safari top sites

RESOLVED DUPLICATE of bug 455553

Status

()

Firefox
General
--
enhancement
RESOLVED DUPLICATE of bug 455553
7 years ago
7 years ago

People

(Reporter: ltinhuynh@gmail.com, Unassigned)

Tracking

4.0 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

7 years ago
Created attachment 565894 [details]
Please modify the firstpage based on Safari's top site idea

The enhancement suggests the first page of the browser when loaded is a page that lists all the favourite sites visited most often by the users. These are called top sites. At first time of using the browser, Firefox can recommend the 10 – 15 top sites based on statistics collected by other users. After that, the browser should keep track of the frequency the user visits a site and make recommendations based on those browsing history. Alternatively, user can define the favourite pages by themselves. This function can be done as a home page rather than hiding all the most visited pages in a single spot in the browser’s top section for a more attractive user interface.
This is how the browser should work if the enhancement is incorporated:
1.	User opens browser.
2.	Homepage is automatically displayed with small previews of all the top sites.
3.	When user clicks at a preview window, the full website is displayed. A “Show top sites” button is also supplied for users to return to the home page.
4.	An edit button is provided in the home page. When clicked, the page enters “edit” mode in which users can remove a top site or add a new top site to the list. 
Attachment: a snapshot of Safari’s homepage is provided in Figure 10 as the idea for Firefox to implement this enhancement.

Updated

7 years ago
Group: core-security
They are already working on it. See Bug 455553.

Please resolve this bug as a duplicate of that bug.

Updated

7 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 455553
You need to log in before you can comment on or make changes to this bug.