Last Comment Bug 693284 - non-debuggable builds (MOZILLA_OFFICIAL) don't expose extracted libraries to gdb
: non-debuggable builds (MOZILLA_OFFICIAL) don't expose extracted libraries to gdb
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: Widget: Android (show other bugs)
: Trunk
: ARM Android
: -- normal (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
Mentors:
Depends on:
Blocks: 687446
  Show dependency treegraph
 
Reported: 2011-10-10 05:29 PDT by Mike Hommey [:glandium]
Modified: 2012-02-08 01:14 PST (History)
0 users
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments

Description Mike Hommey [:glandium] 2011-10-10 05:29:16 PDT
Bug 687446 doesn't work on non-debuggable builds (<application android:debuggable="false">), which all nightlies are :(

This is due to /proc/self/auxv not being readable in such case. There are fortunately other (but less convenient, and more error prone) ways to get this data.
Comment 1 Mike Hommey [:glandium] 2012-02-08 01:14:42 PST
This was fixed by bug 683127

Note You need to log in before you can comment on or make changes to this bug.