If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Pressing escape undoes programmatic value changes in text input

RESOLVED DUPLICATE of bug 598819

Status

()

Toolkit
Form Manager
RESOLVED DUPLICATE of bug 598819
6 years ago
6 years ago

People

(Reporter: Scott González, Unassigned)

Tracking

6 Branch
x86
All
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:6.0.2) Gecko/20100101 Firefox/6.0.2
Build ID: 20110902133214

Steps to reproduce:

Programmatically changed the value of a text field in response to a keypress, then pressed escape.


Actual results:

Pressing escape reverted the value.


Expected results:

Nothing.
(Reporter)

Updated

6 years ago
(Reporter)

Comment 1

6 years ago
This was originally filed as a bug against jQuery UI's autocomplete plugin: http://bugs.jqueryui.com/ticket/7752

Comment 2

6 years ago
Confirming on the testcase in the URL. The ESC only works (undoes the change) if the focus stays in the input field (Enter keeps the focus there). If clicking outside of the field (removing focus from it), the ESC has no effect. Esc also has no effect if javascript is disabled. So it is not used as a general UNDO mechanism, just to undo the automatic field value change.
Status: UNCONFIRMED → NEW
Component: General → DOM: Events
Ever confirmed: true
OS: Mac OS X → All
Product: Firefox → Core
QA Contact: general → events
Yay autocomplete...
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Component: DOM: Events → Form Manager
Product: Core → Toolkit
QA Contact: events → form.manager
Resolution: --- → DUPLICATE
Duplicate of bug: 598819
You need to log in before you can comment on or make changes to this bug.