Last Comment Bug 693301 - Remove ConstructProxyObject
: Remove ConstructProxyObject
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: DOM (show other bugs)
: Trunk
: All All
: -- normal (vote)
: mozilla10
Assigned To: Peter Van der Beken [:peterv]
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-10-10 07:24 PDT by Peter Van der Beken [:peterv]
Modified: 2011-10-13 07:14 PDT (History)
2 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
v1 (5.56 KB, patch)
2011-10-10 07:24 PDT, Peter Van der Beken [:peterv]
mrbkap: review+
Details | Diff | Review

Description Peter Van der Beken [:peterv] 2011-10-10 07:24:05 PDT
Created attachment 565936 [details] [diff] [review]
v1

We can construct the outer window proxy from WrapObject.
Comment 1 Blake Kaplan (:mrbkap) (please use needinfo!) 2011-10-10 15:05:37 PDT
Comment on attachment 565936 [details] [diff] [review]
v1

Review of attachment 565936 [details] [diff] [review]:
-----------------------------------------------------------------

::: dom/base/nsGlobalWindow.h
@@ +302,5 @@
> +  // nsWrapperCache
> +  JSObject *WrapObject(JSContext *cx, XPCWrappedNativeScope *scope,
> +                       bool *triedToWrap)
> +  {
> +    *triedToWrap = IsOuterWindow();

I think you should be able to assert that this is true since we don't QI to nsWrapperCache for inner windows.
Comment 2 Peter Van der Beken [:peterv] 2011-10-12 03:06:19 PDT
https://hg.mozilla.org/integration/mozilla-inbound/rev/82fd332d288a
Comment 3 Marco Bonardo [::mak] 2011-10-13 07:14:07 PDT
https://hg.mozilla.org/mozilla-central/rev/82fd332d288a

Note You need to log in before you can comment on or make changes to this bug.