Closed Bug 693369 Opened 10 years ago Closed 3 years ago

Fullscreen video goes way back

Categories

(Core :: Audio/Video: Playback, defect)

x86_64
Linux
defect
Not set
normal

Tracking

()

RESOLVED INACTIVE

People

(Reporter: benjamin, Unassigned)

References

Details

I saw this today, but I've seen similar stuff in the past and apparently it isn't filed:

* Watch air mozilla live (I was using the "new" stream)
* After some stream stopping and starting, probably due to my slowish network, I chose to go fullscreen by right-clicking the video element
* It showed fullscreen but went "back" several minutes in the video. In the past fullscreen has been entirely black or had the spinner without any video.

I'm happy to take logs if there is anything interesting about my setup.
When a video goes full-screen, we currently open a new window and place a clone of the <video> element into the new window. Not sure why that is causing the video clone to seek backwards, but regardless this problem will go away when we enable the DOM full-screen API, since we're going to switch to using that for video full-screen.
Depends on: 545812
This would be worth checking now that bug 545812 has landed.
Even if the symptoms are fixed by bug 545812, we should keep this bug open because it indicates a possible bug in mozLoadFrom which needs further investigation.
Component: Audio/Video → Audio/Video: Playback
Mass closing do to inactivity.
Feel free to re-open if still needed.
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → INACTIVE
You need to log in before you can comment on or make changes to this bug.