Service.startOver resets Status.sync too late, prefs pane flickers

RESOLVED FIXED in Firefox 8

Status

Cloud Services
Firefox Sync: Backend
RESOLVED FIXED
6 years ago
5 years ago

People

(Reporter: philikon, Assigned: philikon)

Tracking

({regression, verified-beta})

unspecified
mozilla10
regression, verified-beta
Points:
---

Firefox Tracking Flags

(firefox8 fixed, firefox9 fixed)

Details

(Whiteboard: [verified in services][qa!][qa!:9])

Attachments

(1 attachment)

This is a tiny regression from bug 691663 that I just found: If you "Unlink This Device" in the Sync prefs pane, the prefs pane flickers and goes back to displaying the page for when you have Sync set up (which is wrong). I believe the reason for that is because we reset Status.sync too late in Service.startOver.

Fix incoming.
Created attachment 566093 [details] [diff] [review]
v1
Attachment #566093 - Flags: review?(rnewman)
Comment on attachment 566093 [details] [diff] [review]
v1

Review of attachment 566093 [details] [diff] [review]:
-----------------------------------------------------------------

::: services/sync/tests/unit/test_service_startOver.js
@@ +37,5 @@
> +
> +  // Verify set up.
> +  do_check_eq(Status.checkSetup(), STATUS_OK);
> +
> +  // Verify state that the observer sees

'.'
Attachment #566093 - Flags: review?(rnewman) → review+
https://hg.mozilla.org/services/services-central/rev/0ab95b85d06e
Status: NEW → ASSIGNED
Whiteboard: [fixed in services]
STRs for QA:

- Choose a profile that has Sync set up (or set up Sync)
- Click on "Unlink This Device" in the Sync prefpane
- ensure the prefpane shows the "Set up Sync" and "Pair a Device" links

Please note: this regression was introduced by bug 691663. "Unlink This Device" is an essential feature of Sync, much like the Sync setup wizard, and should be part of every smoketest.
(Assignee)

Updated

6 years ago
status-firefox8: --- → affected
status-firefox9: --- → affected
Comment on attachment 566093 [details] [diff] [review]
v1

Requesting approval for Beta and Aurora since bug 691663 which caused this tiny regression was landed in those places last week. I apologize for causing that and made sure to follow up with QA since the regression should really have been found when running smoketests against bug 691663 (which we did before landing in Aurora and Beta).
Attachment #566093 - Flags: approval-mozilla-beta?
Attachment #566093 - Flags: approval-mozilla-aurora?
Mozilla/5.0 (Windows NT 6.1; rv:10.0a1) Gecko/20111011 Firefox/10.0a1
Mozilla/5.0 (Windows NT 5.1; rv:10.0a1) Gecko/20111011 Firefox/10.0a1
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:10.0a1) Gecko/20111011 Firefox/10.0a1
Mozilla/5.0 (X11; Linux i686 on x86_64; rv:10.0a1) Gecko/20111011 Firefox/10.0a1

ID: 20111011093957

Verified the fix on the above builds.
After unlinking a device, the "Set Up Sync" and "Pair a device" pane is shown and no flickering observed.
Whiteboard: [fixed in services] → [fixed in services] [verified in services]

Updated

6 years ago
Whiteboard: [fixed in services] [verified in services] → [verified in services]
https://hg.mozilla.org/mozilla-central/rev/0ab95b85d06e
Status: ASSIGNED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla10

Updated

6 years ago
Attachment #566093 - Flags: approval-mozilla-beta?
Attachment #566093 - Flags: approval-mozilla-beta+
Attachment #566093 - Flags: approval-mozilla-aurora?
Attachment #566093 - Flags: approval-mozilla-aurora+
https://hg.mozilla.org/releases/mozilla-aurora/rev/0cb1870e32d2
status-firefox9: affected → fixed
https://hg.mozilla.org/releases/mozilla-beta/rev/446adf5e2672
status-firefox8: affected → fixed
Whiteboard: [verified in services] → [verified in services][qa+]
Mozilla/5.0 (X11; Linux i686 on x86_64; rv:9.0) Gecko/20100101 Firefox/9.0
Mozilla/5.0 (Windows NT 6.1; rv:9.0) Gecko/20100101 Firefox/9.0
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:9.0) Gecko/20100101 Firefox/9.0

Verified on 9beta5 using the steps from comment #4 and no flicker was observed; device unlinked successfully
Keywords: verified-beta
Whiteboard: [verified in services][qa+] → [verified in services][qa+][qa!:9]

Updated

5 years ago
Whiteboard: [verified in services][qa+][qa!:9] → [verified in services][qa!][qa!:9]
You need to log in before you can comment on or make changes to this bug.