Last Comment Bug 693467 - Firefox 10.0a1 Crash @ mozilla::plugins::PluginModuleParent
: Firefox 10.0a1 Crash @ mozilla::plugins::PluginModuleParent
Status: VERIFIED FIXED
: crash, regression
Product: Core
Classification: Components
Component: Plug-ins (show other bugs)
: Trunk
: x86 Windows 7
: -- critical (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
:
Mentors:
Depends on: 581341
Blocks:
  Show dependency treegraph
 
Reported: 2011-10-10 15:34 PDT by Marcia Knous [:marcia - use ni]
Modified: 2011-10-24 12:02 PDT (History)
2 users (show)
See Also:
Crash Signature:
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments

Description Marcia Knous [:marcia - use ni] 2011-10-10 15:34:25 PDT
Seen while reviewing crash stats. Low volume Windows 7 only trunk only crash that started showing up in crash stats using 2011100600 build. https://crash-stats.mozilla.com/query/query?query_type=simple&do_query=1&query=mozilla%3A%3Aplugins%3A%3APluginModuleParent%3A%3AWriteExtraDataForMinidump%28nsDataHashtable%3CnsCStringHashKey%2C+nsCString%3E%26%29

Possible regression range: http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=70e4de45a0d0&tochange=8c82de08425d

https://crash-stats.mozilla.com/report/index/131539b9-18b0-462a-a6a8-5e5b82111010

Frame 	Module 	Signature [Expand] 	Source
0 	xul.dll 	mozilla::plugins::PluginModuleParent::WriteExtraDataForMinidump 	dom/plugins/ipc/PluginModuleParent.cpp:192
1 	xul.dll 	PL_DHashTableInit 	obj-firefox/xpcom/build/pldhash.cpp:272
2 	xul.dll 	mozilla::ipc::RPCChannel::Call 	ipc/glue/RPCChannel.cpp:191
3 	xul.dll 	nsTHashtable<nsBaseHashtableET<nsCStringHashKey,nsCString> >::Init 	obj-firefox/dist/include/nsTHashtable.h:348
4 	xul.dll 	mozilla::plugins::PluginModuleParent::ActorDestroy 	dom/plugins/ipc/PluginModuleParent.cpp:272
5 	xul.dll 	mozilla::plugins::PPluginModuleParent::DestroySubtree 	obj-firefox/ipc/ipdl/PPluginModuleParent.cpp:1556
6 	mozutils.dll 	je_free 	memory/jemalloc/jemalloc.c:6271
7 	xul.dll 	mozilla::plugins::PPluginModuleParent::OnChannelError 	obj-firefox/ipc/ipdl/PPluginModuleParent.cpp:1244
8 	xul.dll 	mozilla::ipc::AsyncChannel::NotifyMaybeChannelError 	ipc/glue/AsyncChannel.cpp:378
9 	mozutils.dll 	arena_dalloc_small 	memory/jemalloc/jemalloc.c:4250
10 	xul.dll 	mozilla::ipc::AsyncChannel::Close 	ipc/glue/AsyncChannel.cpp:195
11 	mozutils.dll 	arena_dalloc 	memory/jemalloc/jemalloc.c:4327
12 	xul.dll 	mozilla::plugins::PluginModuleParent::NP_Shutdown 	dom/plugins/ipc/PluginModuleParent.cpp:812
13 	xul.dll 	mozilla::plugins::PluginModuleParent::~PluginModuleParent 	dom/plugins/ipc/PluginModuleParent.cpp:158
14 	xul.dll 	Pickle::~Pickle 	ipc/chromium/src/base/pickle.cc:64
15 	xul.dll 	mozilla::plugins::PluginModuleParent::`vector deleting destructor' 	
16 	xul.dll 	nsNPAPIPlugin::~nsNPAPIPlugin 	dom/plugins/base/nsNPAPIPlugin.cpp:261
17 	xul.dll 	nsNPAPIPlugin::`scalar deleting destructor' 	
18 	xul.dll 	ContextHolder::Release 	accessible/src/base/NotificationController.cpp:80
19 	xul.dll 	nsNPAPIPlugin::CreatePlugin 	dom/plugins/base/nsNPAPIPlugin.cpp:485
20 	xul.dll 	mozilla::FramePropertyTable::Get 	layout/base/FramePropertyTable.cpp:105
21 	xul.dll 	CreateNPAPIPlugin 	dom/plugins/base/nsPluginHost.cpp:1646
22 	xul.dll 	nsIFrame::ApplySkipSides 	layout/generic/nsFrame.cpp:778
23 	xul.dll 	nsIFrame::GetPaddingRectRelativeToSelf 	layout/generic/nsFrame.cpp:793
24 	mozutils.dll 	arena_dalloc 	memory/jemalloc/jemalloc.c:4327
25 	mozutils.dll 	arena_malloc_small 	memory/jemalloc/jemalloc.c:3829
26 	xul.dll 	nsEventStateManager::QueryInterface 	content/events/src/nsEventStateManager.cpp:984
27 	xul.dll 	nsNodeWeakReference::QueryReferent 	obj-firefox/xpcom/build/nsWeakReference.cpp:151
28 	mozutils.dll 	je_malloc 	memory/jemalloc/jemalloc.c:5997
29 	xul.dll 	nsEventStateManager::Release 	content/events/src/nsEventStateManager.cpp:987
30 	xul.dll 	nsPluginHost::EnsurePluginLoaded 	dom/plugins/base/nsPluginHost.cpp:1655
31 	xul.dll 	nsACString_internal::Equals 	xpcom/string/src/nsTSubstring.cpp:600
32 	xul.dll 	nsPluginHost::GetPlugin 	dom/plugins/base/nsPluginHost.cpp:1687
33 	xul.dll 	nsPluginHost::TrySetUpPluginInstance 	dom/plugins/base/nsPluginHost.cpp:1262
34 	mozutils.dll 	arena_dalloc 	memory/jemalloc/jemalloc.c:4327
35 	mozutils.dll 	arena_dalloc 	memory/jemalloc/jemalloc.c:4327
36 	mozutils.dll 	arena_malloc_small 	memory/jemalloc/jemalloc.c:3829
37 	mozutils.dll 	je_free 	memory/jemalloc/jemalloc.c:6271
38 	mozutils.dll 	arena_malloc 	memory/jemalloc/jemalloc.c:3891
39 	mozutils.dll 	je_malloc 	memory/jemalloc/jemalloc.c:5997
40 	xul.dll 	nsVoidArray::operator= 	obj-firefox/xpcom/build/nsVoidArray.cpp:366
41 	xul.dll 	nsStringBuffer::Alloc 	xpcom/string/src/nsSubstring.cpp:209
42 	xul.dll 	nsACString_internal::Equals 	xpcom/string/src/nsTSubstring.cpp:600
43 	xul.dll 	nsCOMArray_base::Clear 	obj-firefox/xpcom/build/nsCOMArray.cpp:178
44 	xul.dll 	nsACString_internal::MutatePrep 	xpcom/string/src/nsTSubstring.cpp:162
45 	xul.dll 	nsViewManager::InvalidateHierarchy 	view/src/nsViewManager.cpp:1634
46 	xul.dll 	nsViewManager::UpdateView 	view/src/nsViewManager.cpp:622
47 	xul.dll 	nsView::InvalidateHierarchy 	view/src/nsView.cpp:570
48 	xul.dll 	nsViewManager::UpdateView 	view/src/nsViewManager.cpp:477
49 	mozutils.dll 	arena_dalloc_small 	memory/jemalloc/jemalloc.c:4250
50 	mozutils.dll 	arena_dalloc 	memory/jemalloc/jemalloc.c:4327
51 	mozutils.dll 	arena_malloc_small 	memory/jemalloc/jemalloc.c:3829
52 	mozutils.dll 	arena_dalloc 	memory/jemalloc/jemalloc.c:4327
53 	xul.dll 	AtomTableMatchKey 	xpcom/ds/nsAtomTable.cpp:144
54 	mozutils.dll 	arena_malloc_small 	memory/jemalloc/jemalloc.c:3829
55 	mozutils.dll 	arena_malloc_small 	memory/jemalloc/jemalloc.c:3829
56 	xul.dll 	AtomTableMatchKey 	xpcom/ds/nsAtomTable.cpp:144
57 	mozutils.dll 	arena_malloc_small 	memory/jemalloc/jemalloc.c:3829
58 	mozutils.dll 	arena_bin_malloc_hard 	memory/jemalloc/jemalloc.c:3632
59 	mozutils.dll 	arena_malloc_small 	memory/jemalloc/jemalloc.c:3829
60 	xul.dll 	NS_IsMainThread_P 	obj-firefox/xpcom/build/nsThreadUtils.cpp:138
61 	xul.dll 	nsCycleCollector::Suspect2 	xpcom/base/nsCycleCollector.cpp:2521
62 	mozutils.dll 	je_malloc 	memory/jemalloc/jemalloc.c:5997
63 	mozutils.dll 	arena_bin_malloc_hard 	memory/jemalloc/jemalloc.c:3632
64 	xul.dll 	NS_CycleCollectorSuspect2_P 	xpcom/base/nsCycleCollector.cpp:3416
65 	mozutils.dll 	arena_malloc_small 	memory/jemalloc/jemalloc.c:3829
66 	mozutils.dll 	arena_dalloc_small 	memory/jemalloc/jemalloc.c:4250
67 	mozutils.dll 	arena_malloc 	memory/jemalloc/jemalloc.c:3891
68 	mozutils.dll 	arena_dalloc 	memory/jemalloc/jemalloc.c:4327
69 	xul.dll 	nsLoadGroup::AggregatedQueryInterface 	netwerk/base/src/nsLoadGroup.cpp:219
70 	xul.dll 	nsPluginHost::SetUpPluginInstance 	dom/plugins/base/nsPluginHost.cpp:1186
71 	xul.dll 	NS_GetWeakReference 	obj-firefox/xpcom/build/nsWeakReference.cpp:115
72 	xul.dll 	nsPluginHost::GetInst 	dom/plugins/base/nsPluginHost.cpp:450
73 	xul.dll 	nsPluginStreamListenerPeer::OnStartRequest 	dom/plugins/base/nsPluginStreamListenerPeer.cpp:656
74 	xul.dll 	nsIFrame::ApplySkipSides 	layout/generic/nsFrame.cpp:778
75 	xul.dll 	nsObjectLoadingContent::OnStartRequest 	content/base/src/nsObjectLoadingContent.cpp:744
Comment 1 Josh Matthews [:jdm] 2011-10-11 13:18:27 PDT
Bug 581341 is the likely candidate for the regression here.
Comment 2 Josh Matthews [:jdm] 2011-10-19 12:37:02 PDT
This should be fixed by the patch in bug 691424.
Comment 3 Josh Matthews [:jdm] 2011-10-23 17:06:16 PDT
I haven't seen a crash since the 20th, so I think this is fixed.
Comment 4 Marcia Knous [:marcia - use ni] 2011-10-24 12:02:46 PDT
Verifying based on crash stats. No crashes since the 20111020031025 build.

Note You need to log in before you can comment on or make changes to this bug.