1.0b7 doesn't install correctly

RESOLVED WONTFIX

Status

Calendar
Lightning Only
RESOLVED WONTFIX
7 years ago
4 years ago

People

(Reporter: Ryan Lovett, Unassigned)

Tracking

Lightning 1.0b7

Details

Attachments

(3 attachments)

(Reporter)

Description

7 years ago
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_5_8) AppleWebKit/535.1 (KHTML, like Gecko) Chrome/14.0.835.202 Safari/535.1

Steps to reproduce:

On TB 7.0.1 on Mac OS X 10.5.8. Used the Add-ons Manager to install Lightning 1.0b7. 


Actual results:

The Mac cursor changed to a spinning wheel and a little while later I was asked if I wanted to wait for a script to finish running. I said yes. After a little while longer, TB said I should restart to enable Lightning so I did. TB automatically opened the Add-ons Manager tab and it says "Lightning will be installed after you restart Thunderbird." I restarted again but it never installs.


Expected results:

Lightning gets installed.
Known issue, unfortunately a platform error. To work around:

* Uninstall Lightning, restart Thunderbird
* Quit Thunderbird
* Go to your profile folder, then into the "extensions" folder.
* Delete the folder {e2fda1a4-762b-4020-b5ad-a41df1933103}
* Start Thunderbird
* Install the latest Lightning again
(Reporter)

Comment 2

7 years ago
Thanks for your help. What is the proper way to uninstall Lightning given the circumstances? There is no uninstall button/link though there is an "Undo" link which doesn't seem to do much. I gather I can destroy the profile altogether but it sounds like I need a profile with some prior Lightning knowledge to make this work.
Oh, a clean profile will work too. I thought maybe you'd like to retain your settings and local calendars though.

You should be able to uninstall using Tools > Addons > Extensions > Click on Lightning > Remove
(Reporter)

Comment 4

7 years ago
Created attachment 566587 [details]
Extensions, pre-click
(Reporter)

Comment 5

7 years ago
Created attachment 566588 [details]
Extensions, post-click
(Reporter)

Comment 6

7 years ago
I've actually tried brand new profiles but the same thing always happens. I was investigating transitioning from Sunbird so I had initially created a new profile with no email accounts and only Lightning.

Unfortunately there is no Remove button in the Extensions pane. Clicking on Lightning doesn't make it appear either. I've tried clicking on Restart now, but TB returns and the Extensions pane looks the same. I attached a couple of screen grabs.
The missing remove button seems to be a bug in Thunderbird/Mozilla. Could you try uninstalling and reinstalling Thunderbird?
(Reporter)

Comment 8

7 years ago
I just tried with Thunderbird 8 and Lightning 1.0 and am seeing the same problem as the original report. I deleted extensions* in my profile directory before trying these new versions.

When I click "Restart now" in the Add-ons Manager, TB dutifully restarts with the manager open and the item for Lightning reading "Lightning will be installed after you restart Thunderbird."
(Reporter)

Comment 9

7 years ago
I found an extensions.log in my profile dir that indicated TB couldn't move the extension out of the staging dir. I shutdown TB , rsynced extensions/staged/ to extensions/, then moved staged/ aside. When I started TB it asked me to confirm the installation of Lighting and restart. I did so and when TB came up again it indicated that TB was installed.

I'm not sure that it is actually installed however because I don't see how I can activate it. Clicking on Preferences within the Extensions pane of the Add-ons Manager brings up the TB prefs window and not a Lightning prefs window.

I'll attach the extensions.log file.
(Reporter)

Comment 10

7 years ago
Created attachment 572883 [details]
extensions.log from my profile dir

Comment 11

7 years ago
(In reply to Ryan Lovett from comment #10)
> Created attachment 572883 [details]
> extensions.log from my profile dir
Resolving as WONTFIX because there are no recent reports of similar problems with a recent version of Lightning. Feel free to file a new bug report if you experience such a problem.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.