Firefox UI quirks appear when changing Windows 7 theme while Firefox is running.

RESOLVED DUPLICATE of bug 656891

Status

()

Core
Widget: Win32
--
minor
RESOLVED DUPLICATE of bug 656891
6 years ago
3 years ago

People

(Reporter: Patrick Ivers, Unassigned)

Tracking

7 Branch
x86
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(3 attachments)

(Reporter)

Description

6 years ago
Created attachment 566442 [details]
Second window in restored state (black title bar)

User Agent: Mozilla/5.0 (Windows NT 6.1; rv:7.0.1) Gecko/20100101 Firefox/7.0.1
Build ID: 20110928134238

Steps to reproduce:

Preconditions:
	- Dual-monitor setup was in "extended display" mode
	- Windows theme was initially set to "Aero"

Exact steps I took:
	1. Launched Firefox.
	2. Maximised the window.
	3. Opened 4 new tabs and directed each tab to a separate YouTube video.
	4. Opened a new FireFox window.
	5. Moved new window to second display and maximised it.
	6. Changed the Windows 7 theme to "Windows Classic".
	7. At this point, visual quirks began to appear such as a strange "edge" around the window. I restored and then maximised the windows.
	8. Changed the Windows 7 theme back to "Aero".
	9. Restored the second Firefox window by dragging the title bar away from the top of the screen.

Description:
	I believe this UI bug is caused by changing the Windows theme while Firefox is running.
	It may only occur when the Firefox windows are in one of the few window states: minimised, restored, maximised.


Actual results:

- The title bar and window controls became black.
- If I attempted to maximise the window again, the title bar would become completely transparent.
- I also wasn't able to close the window by clicking the "x" button (it wasn't there).


Expected results:

- The window theme should have correctly transitioned to the matching Windows 7 theme
(Reporter)

Comment 1

6 years ago
Created attachment 566443 [details]
Second window in maximised state (transparent title bar)
(Reporter)

Updated

6 years ago
Attachment #566442 - Attachment description: bug2_screen_2.png → Second window in restored state.
(Reporter)

Updated

6 years ago
Attachment #566442 - Attachment description: Second window in restored state. → Second window in restored state (black title bar).
(Reporter)

Updated

6 years ago
Attachment #566442 - Attachment description: Second window in restored state (black title bar). → Second window in restored state (black title bar)
(Reporter)

Updated

6 years ago
Summary: Firefox UI quirks appear when changing Windows 7 themes while Firefox is running. → Firefox UI quirks appear when changing Windows 7 theme while Firefox is running.
(Reporter)

Updated

6 years ago
Severity: normal → minor

Updated

6 years ago
Component: Theme → Widget: Win32
Product: Firefox → Core
QA Contact: theme → win32
(Reporter)

Comment 2

6 years ago
Created attachment 566558 [details]
Second window in restored state (black title bar). version 2.

Comment 3

3 years ago
This is most likely a dupe of bug 656891.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 656891
You need to log in before you can comment on or make changes to this bug.