autocompletion expire preference

VERIFIED WONTFIX

Status

SeaMonkey
Location Bar
P3
minor
VERIFIED WONTFIX
17 years ago
10 years ago

People

(Reporter: Joakim Recht, Assigned: Blake Ross)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux 2.4.2-pre1 i686; en-US; 0.8) Gecko/20010219
BuildID:    2001021906

Manually entered URLs should not be expired, or it should be possible to set for
how long they should be autocompleted. At the moment, URLs are removed from the
auto completion feature after a while, which is pretty annoying.

Reproducible: Always
Steps to Reproduce:
Enter URL
Wait a couple of days (how many is unknown)


Actual Results:  URL is not autocompleted anymore

Expected Results:  Autocompletion should be preserved
(Assignee)

Comment 1

17 years ago
They expire?  The urlbar's history is limited by number, not date, is it not?  
And urlbar autocompletion reads from the same datasource as urlbar history.

Comment 2

17 years ago
yeah, what Blake said. You(reporter(god)) seem to type in a lot of url's. The datasource
is capped at 50 or 100 or something like that. Maybe if alecf is feeling nice he'll tell you
where/which pref to hand edit to change this to an arbitrarily large number.

somebody click verified so I don't look like an overbearing meanie but both resolving and
verifying this as WONTFIX (unless of course I'm wrong)
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → WONTFIX
(Assignee)

Comment 3

17 years ago
Looks like it can hold 100 items, and we display up to 15 in the menu.  These 
actually aren't prefs, it seems, they're constants in sessionHistoryUI.js.

I'll verify it ;-)
Status: RESOLVED → VERIFIED
(Reporter)

Comment 4

17 years ago
How about making it an adjustable value, then? Of course, one could just use
bookmarks instead, but for some reason I like the autocompletion feature
better... Keeps the number of bookmarks down.

Comment 5

17 years ago
if I recall correctly, it's not capped...

Comment 6

17 years ago
sorry, didn't read the whole bug, it is capped, my bad :)
sure, we could make this a hidden pref
Status: VERIFIED → UNCONFIRMED
Resolution: WONTFIX → ---

Comment 7

17 years ago
Marking NEW & changing summary.
URL: n/a
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: don't expire autocompletion urls → autocompletion expire preference

Updated

17 years ago
Status: NEW → ASSIGNED
Priority: -- → P3
Target Milestone: --- → mozilla1.0

Comment 8

17 years ago
nav triage team:

Not a mozilla1.0 stopper, marking mozilla1.1
Target Milestone: mozilla1.0 → mozilla1.1

Comment 9

17 years ago
reassign url bar bugs to new owner..
Assignee: alecf → blakeross
Status: ASSIGNED → NEW
Target Milestone: mozilla1.1 → ---
(Assignee)

Comment 10

17 years ago
I'm not in the hidden pref business to add prefs that only please a few users,
sorry.
Status: NEW → RESOLVED
Last Resolved: 17 years ago17 years ago
Resolution: --- → WONTFIX
mass-verifying WontFix bugs which haven't changed since 2001-12-31.

use the search string "BoletusEdulis" if you want to filter out this msg.
Status: RESOLVED → VERIFIED
Product: Core → SeaMonkey
You need to log in before you can comment on or make changes to this bug.