Last Comment Bug 694133 - Switching tabs should not undo rearrangement of tabs [3-finger drag]
: Switching tabs should not undo rearrangement of tabs [3-finger drag]
Status: RESOLVED FIXED
fixed by bug 690227
:
Product: Firefox
Classification: Client Software
Component: Tabbed Browser (show other bugs)
: Trunk
: x86_64 Mac OS X
: -- normal (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
: Dão Gottwald [:dao]
Mentors:
Depends on: 690227
Blocks: 455694
  Show dependency treegraph
 
Reported: 2011-10-12 14:03 PDT by Jesse Ruderman
Modified: 2013-11-12 00:57 PST (History)
2 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments

Description Jesse Ruderman 2011-10-12 14:03:22 PDT
1. Set "System Preferences" > "Trackpad" > "Three Fingers" to "Dragging".
2. Using three fingers, drag a tab to change its position in the tab strip.
3. Just after dragging, switch tabs using the keyboard (e.g. Ctrl+Tab).

Result: tabs switch back to their original positions.

This might have something to do with Mac OS X not considering the drag to be "complete" until about a second after I lift my finger.

I'm not sure if this bug predates the fix for bug 455694, but it's certainly more noticeable now that tab dragging feels more like direct manipulation than a mode.
Comment 1 Frank Yan (:fryn) 2011-11-28 15:05:11 PST
No, it doesn't predate bug 455694. The original fix for bug 455694 had this problem because of an oversight I had. The fix in bug 674925 doesn't have that problem.

Note You need to log in before you can comment on or make changes to this bug.