Last Comment Bug 694227 - nsIBaseWindow::blurSuppression is not used
: nsIBaseWindow::blurSuppression is not used
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: Widget (show other bugs)
: Trunk
: All All
: -- normal (vote)
: mozilla10
Assigned To: Neil Deakin
:
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-10-12 18:41 PDT by Neil Deakin
Modified: 2011-10-18 06:38 PDT (History)
2 users (show)
enndeakin: in‑testsuite-
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
patch (11.10 KB, patch)
2011-10-12 18:41 PDT, Neil Deakin
benjamin: review+
bzbarsky: superreview+
Details | Diff | Splinter Review

Description Neil Deakin 2011-10-12 18:41:44 PDT
Created attachment 566720 [details] [diff] [review]
patch

Let's remove it.
Comment 1 Benjamin Smedberg [:bsmedberg] 2011-10-13 09:48:52 PDT
Comment on attachment 566720 [details] [diff] [review]
patch

LGTM, although I wonder whether we should actually be doing something with this flag. Did you grep addons to see whether anyone else is using it?
Comment 2 Boris Zbarsky [:bz] (still a bit busy) 2011-10-13 11:31:02 PDT
Comment on attachment 566720 [details] [diff] [review]
patch

r=me
Comment 3 Neil Deakin 2011-10-14 06:01:58 PDT
(In reply to Benjamin Smedberg  [:bsmedberg] from comment #1)
> Comment on attachment 566720 [details] [diff] [review] [diff] [details] [review]
> patch
> 
> LGTM, although I wonder whether we should actually be doing something with
> this flag. Did you grep addons to see whether anyone else is using it?

It was used as a fix for a crash bug where modal dialogs were opened and the main window closed while blurred. I can't reproduce it any more.
Comment 4 Ed Morley [:emorley] 2011-10-15 05:32:00 PDT
https://hg.mozilla.org/mozilla-central/rev/697558811978

Note You need to log in before you can comment on or make changes to this bug.